Arduino Nano Ethernet Gateway not working



  • Hi all,

    First of all, great community here! learned a lot!!

    Althougt i'm a really rookie in all of this.

    I've built som temperature nodes, with ds18b20 + nrf24l01 + arduino pro mini.
    built a serial gateway and everything worked fine in domoticz.

    now, i want to do some other trial, and its a fail over a fail.
    i've a arduino nano+enc28j60+nrf24l01.
    ive used the connection diagram avail here: https://www.mysensors.org/build/ethernet_gateway
    I've used also the code avail in the link above. changed the ip, mac addr, loaded to the arduino, and got the error 0;0;3;0;9;radio init fail.
    Uncomment the softspi in myconfig.h, like i've saw in the forum. i was so thriled this would work, and i've got the error my sketch was too big. (just uncommented softspi).

    in this point, i'm asking, if someone can help me.

    Many thanks in advance


  • Hardware Contributor

    I can't help you much on this as I have not this setup but tried once.

    • w5100 module works better if you can get one.
    • you're right you need to enable sofspi.

    If sketch is too big, you may have MY_DEBUG enabled. Try to comment it. this should compile. I mean if you have not added too much things in your sketch 😉



  • Hi scalz,

    Thanks for your reply.

    I've tested that, and the sketch did compile. However, did not worked.

    I've tested all the connections. everything is ok. simple does not work.

    Someone have a code that works, so that i can use?
    Thanks in advance


  • Hardware Contributor

    @andmaster arghh! I'm sorry to hear this. and I have not so much time to have a look. if i have a bit of time i will try, but no promise on my side.
    so now that it compile. do you have some logs? what's the behaviour? maybe if i get an idea..



  • Well, the behaviour is odd. it blinks but nothing shows in the serial monitor. Also, domoticz dont find it..
    i will try other things 😉

    thanks anyway


 

317
Online

7.9k
Users

8.8k
Topics

93.8k
Posts