MySensors node floods 2.4GHz band



  • Hi Guys

    I have some strange problem with my new node - I'm building kind of remote control to Roomba device and I've found that my node (Arduino+NRF24 + MySensors 2.0) based after couple of minutes hangs and floods 2.4 GHz band with large amount of packets. Flood is so large that my WiFi almost stops working. Device stops output on Serial (I don't have more detailed debug, only standard output to serial what means nothing), constatly flashes with L LED (PIN13). Interesting thing is that watchdog doesn't trigger, so I assume that device works (almost) correctly, but doesn't work in a way I expect it. Actually it doesn't report anything. One (maybe) important thing is a moment of failure - usually it occurs a few moments after Roomba goes to sleep (what causes serial errors, but they are handled already), but I think it is rather a coincidence (when I put it in sleep manually, everything works, for a moment), so I assume it is rather connected with time than such event. Gateway is Raspberry based with output to MQTT.

    I use SoftSerial, roomba and MySensors libraries in my script, but without any hacks.

    Do you have any ideas?


  • Mod

    @emka I would guess there is a mistake somewhere in the sketch



  • But sketch is very simple - it reports is state every defined time, communicates using serial with roomba and (potentially) receives couple of defined commands. Nothing comlicated, and as I wrote before it works. After couple of minutes it stops working and I assume the problem is somewhere in library because Arduino reports constant transmitions (with blinking LED). Watchdog also doesn't trigger so there is no hang. I assume that in case of some loop in sketch, node would start constant transmission of some data, but it doesn't transmit anything understandable by mySensors. More, it doesn't show any transmission on serial. Only blinks a LED and WiFi stops (almost) working.


  • Hardware Contributor

    Even if it's simple ;), that would be easier for us with more infos..

    • Source of your GW firmware if you have not changed it. If changed, please post your changes.
    • Source of your node sketch. Same as above.
    • how it's wired with your roomba.
    • you say it worked before, but it stops after couple minutes..?? So it doesn't work completely? Or it worked before, and what have you changed?
    • and the logs

    Why not adding debug lines in your code to see where it bugs. Or use an external led if you want.


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.