Help needed to beginner

  • Re: openHAB 2.0 binding

    I have openHAB 2 latest snapshot installed on Raspberry Pi 3 model B. I have installed MySensors Binding for OpenHAB 2.x as described in here:
    MySensors binding can be found from openHAB PaperUI.
    My Problem is that I can't get gateway working. I have connected NRF24L01+ and installed gateway as described in here:

    My questions are:

    1. should I leave gateway to ethernet or change it to serial?
    2. which one should I choose in openHAB binding, serial or ethernet gateway?
    3. should I run some of these commands during gateway installation:

    -"By default, the gateway is built for ethernet and it listens on port 5003:
    ./configure --my-gateway=ethernet --my-port=5003

    -To set the gateway as a client that connects to a controller, use:
    ./configure --my-gateway=ethernet --my-controller-url-address=YOUR-CONTROLLER-ADDRESS
    ./configure --my-gateway=ethernet --my-controller-ip-address=YOUR-CONTROLLER-IP


  • @TommiP Got the same config Rpi3 model B with open hab 2. I use this config and it can connect to gateway on same box. Ehternet is whats supported with OpenHaB

    ./configure --my-gateway=ethernet --my-leds-err-pin=12 --my-leds-rx-pin=16 --my-leds-tx-pin=18 --my-transport=nrf24 --my-rf24-irq-pin=15
    If you run it in debug mode what is the output then?

    I dont get my nodes to connect to Gateway atm but everything else looks like it works.

  • @keldandorin
    If you mean by debug this:
    pi@raspberrypi:~/MySensors $ sudo ./bin/mysgw -d
    it gives endlessly this:
    mysgw: accept: Bad file descriptor

    I think this problem has something to do with Rpi3 and GPIO uart/serial problem described in here?:
    and here?:

  • Mod

    Gpio serial problem should not have anything to do with that if you are using ethernet gateway. I'm on rpi3 and I followed the guide and it worked fine.

  • @gohan

    Ok, good to know, Thanks for information gohan.
    When you installed gateway, did you run these commands?:
    ./configure --my-gateway=ethernet --my-controller-url-address=YOUR-CONTROLLER-ADDRESS
    ./configure --my-gateway=ethernet --my-controller-ip-address=YOUR-CONTROLLER-IP


  • Mod

    I don't think I specified those ip or URL addresses, I need to check in my notes

  • Ok, now I got gateway working and openHAB 2 latest snapshot reading temperature sensor. Only thing did not work automatically was Thing auto discovery in openHAB. I needed manually add things ( MySensors Ethernet Gateway and Temperature Sensor).
    Temperature sensor Node ID and Child ID needed to be checked from log and manually put in Thing settings.
    Ethernet Gateway needed also IP manually put in.

    This is what I made:

    • install fresh openHABian to Rpi3
    • update openhab to latest snapshot
    • install MySensors gateway, stop installation commands after:
      To install run:
      sudo make install
    • install MySensors openhab 2 binding
    • manually added things (with values) in openhab


  • @TommiP
    From my experience the node has to be "rebooted" while openhab2 is discovery mode for new devices in that binding...
    Just press "rest" button on your arduino
    Works every time!

Log in to reply

Suggested Topics

  • 22
  • 1
  • 135
  • 3
  • 7
  • 10