Help needed in getting Gateway and nodes working with Openhab on a Raspberry pi



  • OK so I really need some help I'm a bit lost at the moment and I'm pulling my hair out. My setup is a Raspberry pi running Openhabian I currently have a nrf24 radio wired to the gpio on the Raspberry exactly as it shows here. I have the Mysensors Binding installed and I can see it in the paper-UI. I've tries to firstly get the gateway running as a serial gateway following the guide which wasn't successful and after a bit of looking on the forum I saw that it was best to use the development version. This improved things I was able to ./bin/mysgw - d successfully and the gateway was showing a successful test. However in the paper-UI when I try to set up the serial gateway Thing through the Mysensors binding is shows as offline. after looking in the /var/syslog I noticed that it said

    Failed to connect on port: /dev/ttyUSB020 exception: gnu.io.NoSuchPortException
    

    So I searched through the forum and saw it mentioned that the Raspberry pi uses AMA0 as it serial port and so I tried again with ./configure and make install, still it would show online

    so I tried again this time choosing Ethernet as my option and following the guide to do that.

    Again still no luck with it showing online in the paper-UI.

    can some one advise me how to start again and at least get this gateway working .


  • Mod

    When gateway running as ethernet, can you connect to it with myscontroller?



  • @gohan when I try running ./bin/mysgw -d it crashes and constantly repeats failed to connect and I have to exit the ssh session.
    Also what is myscontroller?


  • Mod

    Can you try another Linux image? I'm very happy with DIETPI. What options did you set in the ./configure? What raspberry version are you using?
    Search forum for myscontroller



  • This is a different image I recently renewed my entire openhab setup on a fresh image to try and get rid of all the problems I've had with openhab. This has worked for openhab and I'm happy with the setup finally. Its Rasbian Jessie, kernal: 4.9.13-v7+ .
    For serial I did

    ./configure --my-transport=nrf24 --my-gateway=serial --my-serial-is-pty --my-serial-pty=/dev/ttyAMA020
    

    For Ethernet I did

    ./configure --my-transport=nrf24 --my-gateway=ethernet --my-controller-ip-address=127.0.0.1  --my-port=5003  
    

    Tim


  • Mod

    What raspberry version are you using?
    --my-controller-ip-address=127.0.0.1 is not necessary
    are you using latest mysensors library from development branch?



  • Oh sorry.... its a raspberry pi 3.
    Yeah I git cloned the development version from the link in the guide not the master.


  • Mod

    it is quite odd that it crashes... I'd still suggest to try another image to do a comparison (i hope you have a spare microsd for the job)



  • I have a few so this is definitely something I can look at to compare and see if it changes the outcome.



  • Good news I deleted everything from the Mysensors gitclone including the file in /usr/local/bin/.

    re-cloned the developement branch and ./configure for Ethernet without IP
    address and after configuring the Ethernet gateway in paper UI its now showing as online
    Thanks for your help @gohan

    also I like the look of myscontroller but its only for windows I only have a linux machine.

    Tim


  • Mod

    there is an android app that does similar job, search play store for "mysgw".



  • @gohan brilliant ! Ive downloaded the app. Out of interest it asks for an IP address to set up.
    When setting up the Ethernet gateway on the paper-UI I set the IP as local host 127.0.0.1 to make it work.

    Do I just put the IP for the raspberry pi on the LAN, for the android app ?


  • Mod

    yes, it requires the ip of the device running the ethernet gateway


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.