RF24:RBR:REG=23,VAL=17



  • I'm having a problem similar to what is described in "NRF24 Radio does not link if MY_DEBUG_VERBOSE_RF24 is not defined. #941" https://github.com/mysensors/MySensors/issues/941. My local branch is up to date with the beta development branch (v2.2.0-beta).

    That issue that I referenced seems to deal with data arriving too quickly from the gateway. I am operating without a gateway doing some testing with PingPong, so I'm not sure the problem is the same. (See below for how I'm shutting off attempts to communicate with a Gateway in case it is relevant).

    I'm getting the same error RF24:RBR:REG=23,VAL=17 repeating endlessly, but only on 328P 3.3v 8MHz boards (knock offs from Robotdyn). I've tried two identical boards with the same results. However, the identical sketch runs fine on my 32u4 (Adafruit Feather). The problem, therefore, seems to be hardware specific. I have swapped radios back and forth and the trouble remains on the 328 even when using the radio that works on the 32u4.

    I have an identical 328p and NRF24 (from the same shipment) up and running under 2.1.1. Something seems to have crept in with the changes in the new beta. What can I do to help debug?

    Assuming that "REG=23" refers to decimal register 23, then looking up the register as hex 17 in the specification, I find this:

    0_1512018083126_Capture.PNG

    If I'm reading the chart right (assuming I'm even in the right place) then it looks like the NRF24 is reporting RX_EMPTY and TX_EMPTY.

    The radios are all NRF24L01+ from Makerfire.

    Shutting off Gateway communication:

    #define MY_TRANSPORT_WAIT_READY_MS 3000
    #define   MY_TRANSPORT_UPLINK_CHECK_DISABLED  //Don't check for uplink
    #define   MY_NODE_ID 199  //Fallback NodeId
    #define   MY_PARENT_NODE_ID  1
    #define   MY_PARENT_NODE_IS_STATIC
    

 

320
Online

7.7k
Users

8.6k
Topics

92.3k
Posts