[SOLVED] Transport device initialization failed - Mqqt gateway

  • Hi,
    I went over a few of the posts that describe similar issue that I'm experiencing, but nothing helped.
    So here is my problem:
    Board: Itead IBoard (link)
    Radio: NRF24L01+ (link) - tried a couple of these
    Sketch: GatewayW5100MQTTClient (link) - I just changed necessary IP addresses (MY_IP_ADDRESS and MY_CONTROLLER_IP_ADDRESS).

    Using Iboard should have been a pretty straightforward. I just plug radio to nRF24L01+ module interface and uploaded the sketch. But, I'm always getting the following error (link).

    I even tried building gateway using Arduino Uno and W5100 R3 Network Ethernet Shield (link), but the error message is the same.

    Am I missing something?
    Any feedback I really appreciated.


  • Mod

    @taserface987 Hi, and welcome to the forum!

    The error "11 !TSM:INIT:TSP FAIL Transport device initialization failed" indicates that the radio failed to initialize correctly.

    I found the schematics of the board (https://www.itead.cc/wiki/images/5/50/SCH_IM120410001_iBoard.pdf) and the AVR SPI bus that usually has a direct connection to the the nRF24 is connected differently:

    Could you try again, pasting following snippet just below #define MY_RADIO_RF24 in your sketch?

    #define MY_SOFTSPI
    #define MY_RF24_CE_PIN        (D3)
    #define MY_RF24_CS_PIN        (D8)
    #define MY_SOFT_SPI_SCK_PIN   (D7)
    #define MY_SOFT_SPI_MISO_PIN  (D6)
    #define MY_SOFT_SPI_MOSI_PIN  (D5)

  • @yveaux It's seems that helped (success log). And I'm little embarrassed that I didn't think to check IBoard specs.

    Thank you.

  • Mod

    @taserface987 no worries, glad I could help!

Log in to reply

Suggested Topics

  • 3
  • 15
  • 1
  • 3
  • 24
  • 2