RPi MQTT Gateway problems...

  • Hello All, I may be asking too much, but here goes.
    I have compiled with these parameters:
    ./configure --my-transport=rf24 --my-gateway=mqtt --my-controller-ip-address= --my-mqtt-publish-topic-prefix=mysensors-out --my-mqtt-subscribe-topic-prefix=mysensors-in --my-mqtt-client-id=mygateway1

    Then I ran make. mysgw starts and runs just fine and seems to be transmitting messages. Here's the output:

    pi@blueberrypi:~/MySensors/bin $ sudo ./mysgw
    Feb 09 22:00:12 ERROR Failed to open log pipe.
    Feb 09 22:00:12 INFO Starting gateway...
    Feb 09 22:00:12 INFO Protocol version - 2.3.2
    Feb 09 22:00:12 DEBUG MCO:BGN:INIT GW,CP=RNNGL--X,FQ=NA,REL=255,VER=2.3.2
    Feb 09 22:00:12 DEBUG TSF:LRT:OK
    Feb 09 22:00:12 DEBUG TSM:INIT
    Feb 09 22:00:12 DEBUG TSF:WUR:MS=0
    Feb 09 22:00:12 DEBUG TSM:INIT:TSP OK
    Feb 09 22:00:12 DEBUG TSM:INIT:GW MODE
    Feb 09 22:00:12 DEBUG TSM:READY:ID=0,PAR=0,DIS=0
    Feb 09 22:00:12 DEBUG MCO:REG:NOT NEEDED
    Feb 09 22:00:12 DEBUG MCO:BGN:STP
    Feb 09 22:00:12 DEBUG MCO:BGN:INIT OK,TSP=1
    Feb 09 22:00:12 DEBUG GWT:RMQ:CONNECTING...
    Feb 09 22:00:12 DEBUG connected to
    Feb 09 22:00:12 DEBUG GWT:RMQ:OK
    Feb 09 22:00:12 DEBUG GWT:TPS:TOPIC=mygateway1-out/0/255/0/0/18,MSG SENT
    Feb 09 22:00:12 DEBUG TSM:READY:NWD REQ
    Feb 09 22:00:13 DEBUG ?TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=20,pt=0,l=0,sg=0,ft=0,st=OK:

    But, It doesn't seem to be hearing my sensors at all. I've double and triple checked build and code. I don't see any problems, but ... nothing.

    I would like to create a local mqtt server that doesn't need a controller, just to receive the rf24 sensor data and publish to mqtt. Cant seem to make it work.
    I've built and rebuilt with different options to no avail.

    I can't see why the gateway is not hearing my sensors. I've tried several schetches...nothing.

    Thanks in advance for any help.

  • Mod

    Hi @traceyp, welcome to the forum!

    If you haven't already, check out https://forum.mysensors.org/topic/666/debug-faq-and-how-ask-for-help/
    It has a flowchart and information on how to efficiently troubleshoot and resolve the most common problems.

    A log from one of the nodes would be useful.

    One strange things is that the log indicates that encryption is enabled, but you didn't specify encryption is the configure command.

  • @mfalkvidd Thanks for the info and the reply. I'm going to start again from scratch and recheck every detail. ill respond again with resolution on completion.
    Thanks again.

Log in to reply

Suggested Topics