Wemos Di Mini v3 not connecting to wifi but classic D1 Mini does...



  • Hi,

    I built a gateway with a Wemos D1 Mini "Classic" - and everything works well.

    But now I flashed the exacty same code on a new Wemos D1 Mini v3.0.0 and I always get the message "cannot find network XXX" (I am paraphrasing) and the gateway is not working. I tried this on 2 new v3 D1 Minis with same result.

    Did anybody experience anything like this? Is there an issue with the v3 D1 Minis? Is there any change in the code necessary? I did some research but I could not find anything particular why the D1 Mini v3 should need different code than the D1 Mini "Classic"

    Any help would be greatly appreciated!!!



  • @maddhin I use Wemos D1 Mini as a gateway and it works perfect. May be there is an issue with your modules? Did you tried the ESP8266 example sketch WiFiScan?



  • it seems like I got a bad batch of D1 Mini v3.0.0s. I ran the sample wifi connect and wifi scan sketches on all 5 purchased boards and all had issues connecting or showing all/most available wifis. One was plain broken and wouldn't even cooperate with Win10... Some Wemos D1 Mini v2 and PROs ran the same sketches just fine. So it seems to be a manufacturer error rather than a problem with the v3 of the D1 Mini...
    So, if you have the choice, stick with the v2 "classic" D1 Mini. Although I didn't buy from a dodgy source, there still seem to be issues with producing the new versions reliably...


Log in to reply
 

Suggested Topics

  • 24
  • 11
  • 11
  • 14
  • 1
  • 6
  • 1
  • 6

138
Online

10.1k
Users

10.6k
Topics

109.0k
Posts