Using OpenHAB, any better (looking) alternatives?

  • Hero Member

    I have been running OpenHAB for a while, and I have it integrated with rfxcom,z-wave, and mySensors (through MQTT). It is working pretty well, and I like the fact that we have configurational files for the bindings and rules. This makes things that much more easy to play with, backup, and restore when something fails :-).

    I'm wondering, though, if there are any better alternatives out to back and support this range of hardware? I briefly tried HomeSeer, but I did not like its reliance on Windows. Are there any other platforms of significance I should check out? I have a relatively powerful Linux server running the home automation software, so anything Linux related is of interest.

    My requirements: Automation (rules for reacting to events), control through a web page and cell phone, data logging with nice visualisation, and, of course, integration with the hardware I'm using (listed in the first sentence).

    If the software is really good I'm fine with its costing some money.

    Any suggestions?

  • Hero Member

    @kolaf Did you take a look at Domoticz? Multi platform. Native support for rfxcom, z-wave and MySensors

  • Hero Member

    @kolaf HomeSeer also runs on Linux although some 3rd party plugins only work on Windows.


  • Hero Member

    Another vote for Domoticz. C++ ... need I say more? Now that it has both serial, ethernet (and soon MQTT?) support it should be the first thing to try. Not as nerdy as OpenHAB perhaps, but it just works. LUA scripting can do a lot if you need something that can't be set in the events editor. Like for instance how I run a python script every time a certain motion sensor triggers that allow for a camera to take a picture and push it to my phone.

    Pidome was pretty cool last time I looked also. It should have progressed a lot since. Don't know about the platform compatibility though, I mean it is Java after all, but it was geared heavily towards the Pi.

  • Hero Member

    @AWI said:


    Thanks for the suggestion of Domoticz, I will definitely look into it a bit more closely.

    Apart from not being as nerdy, are there any other features that set it apart (above) OpenHAB?

  • @bjornhallberg I use domoticz for some reed sensors. I am about to create a sensor that plays a tone and lights a LED when they are opened - What is best way to do this? Via the controller scripts or direct comms from the sensors? I have tucked away the sensors so don't really want to reprogram but if its best option then I will!


  • Hero Member

    The latest version of domoticz is apparently broken, but I think it compiles with a version from a few days ago... Typical πŸ™‚

  • Hero Member

    @shabba I guess any approach would work, if your sensor is awake and listening for incoming messages. I actually have a similar idea for the front porch where I will use an audio player module (WTV020-SD-16P - glitchy stuff but easy to find) and an amplifier (PAM8403) with a pair of 4Ξ© 3W speakers to get prospective visitors to crap their pants. It seems best to have the sensor do the triggering in that case. But why not have it set up to play another file as a warning or alarm when triggered from the controller.

  • Hero Member

    @kolaf I do not have experience with OpenHAB, so hard to say. I appreciate the learning curve for Domoticz and ability to do the nerdy stuff in Lua and JSON from Python. To be honest ;I still have my own Python-JSON script running to interface between Domoticz and MySensors as there is no broad native support for requesting variables. (especially eg. V_KWH, I use MySensors also to display information in the whole building. πŸ˜‰ )

  • Hero Member

    @kolaf said:

    The latest version of domoticz is apparently broken, but I think it compiles with a version from a few days ago... Typical πŸ™‚

    No, it doesn't 😯

  • Downloaded Domoticz and had it set up and running in ~15 min on a beaglebone black. Had a little bit of trouble getting my serial gateway to show up. It looks like Domoticz will only look for serial ports in the form of /dev/ttyUSB##. Since I am using the UARTS on the beaglebone it did not work right off. On a hunch I added a symlink:

    sudo ln -s /dev/ttyO4 /dev/ttyUSB2

    Worked like a charm. I have been using openhab for a few months and like it, however I was able to do in Domoticz in 15 min what took hours to figure out in openhab, and the graphs looks a lot better in Domoticz also.

  • @kolaf said:

    @kolaf said:

    The latest version of domoticz is apparently broken, but I think it compiles with a version from a few days ago... Typical πŸ™‚

    No, it doesn't 😯

    in ubuntu not compile the lastest version.

  • Hero Member

    Eventually I got it to compile by deleting my current subversion version and doing a new checkout of revision 2361. I think the reason why this didn't work the first time was that I wasn't able to clean the compile environments enough after checking out the earlier version. This revision is reported to work by many people in the forum, and for me as well.

    I have spent the past few days playing with it, and I have it controlling my zwave network, my nexa and Oregon scientific devices through rfxcom, and finally my mysensors devices, all without any additional plug-ins πŸ™‚

    I have also managed to get mqtt working space by using the approach outlined in the wiki, but I have no idea how to access the apparently built-in mqtt support. My plan for today is to post notification messages to my mqtt broker so that they can be picked up by mqttwarn.

    I like that they have a graphical rule building interface, this makes it easy for new users, but I found that I quickly reverted to the lua scripting functionality. Both because it is much more powerful, and it's actually faster to work with this than a graphical interface πŸ™‚

  • @reddy11 could you please help (step-by-step) how to determine which /dev/tty is UART and how to connect Arduino to it? (RX->TX, TX->RX + Vcc + Gnd is everything I need?)

    I'd like to write a Wiki about it, but first I have problems with connecting arduino serial output to OrangePi (never used it, to be honest, neither GPIO or UART).

  • Admin

    I succeeded in compiling the latest domoticz, found a post on the domoticz forum ( that solved the issue.

    Basically what happens is, that cmake finds the wrong libcurl libraries to include in the build. You have to specify it on the command line with -DCURL_LIBRARY like

    cmake -DCMAKE_BUILD_TYPE=Release -DCURL_LIBRARY=/usr/lib/arm-linux-gnueabihf/ CMakeLists.txt

    Above is for building on raspberrypi.

  • @kolaf I was wondering what you needed to do to get MQTT working with the MySensors and Domoticz. Can you point me in the right direction for that?

  • Hero Member

    Sorry, I used the native mysensors support, not mqtt.

Log in to reply

Suggested Topics

  • 5
  • 2
  • 3
  • 22
  • 1
  • 4
  • 15
  • 23