Serial Gateway Failure


  • Hero Member

    Saturday i lost my serial gateway after several months without a problem. The Serial Port "went away" and I was unable to re-establish it, Vera did not offer the opportunity to configure it. I reloaded Vera gateway files, restarted, time and time again with the same result. It looked like it could be the Vera Lite USB so I ended up replacing the Vera. After a comedy of errors with it auto-upgrading to UI6 and having to fallback to UI5 I finally got it restored to the last backup of Saturday.

    Well, I was still unable to get the gateway running, it still would not establish a serial port. I swapped the Arduino Nano and the USB cable thinking those might be at fault. I finally got the option to configure the serial port and reacquired the sensors. Then I powered the Vera off to put it in its operating location and when it came back up there was no serial port and no options to re-establish it.

    Needless to say this is frustrating. Has anyone else seen this kind of behavior on the serial gateway? I now have a new Vera and it looks like that might not have been the problem in the first place :(


  • Admin

    No, I haven't seen this behavior. Sometimes I've had to restart Vera to get serial ports back when fiddling too much pulling/inserting usb while reloading luup-engine.

    Is the old/new Nano recognized/working when you use it in a computer?


  • Hero Member

    @hek I haven't had time to try the old Nano in anything else. But BOTH Nanos show the Green LED periodically when the sensors transmit so they are apparently good and working on the "other than USB" side :)

    The strange thing was i fiddled with it a number of times and then Bingo, the Serial Port stuff appeared. It worked, I was able to reacquire the sensors and everything looked fine. The I powered it off/on to move and and when it came back up nothing.


  • Admin

    Don't you just love how unpredictable Vera is... ;)


  • Hero Member

    @hek Well actually "Love" isn't QUITE the word I would use :)


  • Contest Winner

    @clippermiami

    I love my mother-in-law, yet at moments I want to choke her out.

    Vera's are a lot like mother-in-laws, yeah?


  • Hero Member

    @BulldogLowell That's on a good day :)

    I just don't know where to go from here. i'm reasonablely confident in the Gateway itself. I don't see how it can be the Nano, its a new unit and it looks like its receiving date from sensors. Its a new unit so the probability of a USB side problem is slim.

    I've reloaded all the Arduino files but i'm tempted to a) remove the gateway, b) delete the files from Vera c) reload Vera files d) reconfigure.

    Any thoughts?


  • Admin

    You might need to ssh into your Vera to see what is happening (or not) when the USB is plugged in. I have seen a thread about how get Vera to recognize odd FTDI versions somewhere but can't seem to find it now.


  • Hero Member

    @hek Good idea, I might try that if I can figure out where to look :)


  • Hero Member

    Further to the saga of the Serial Gateway failure, I have discovered that Vera/Arduino are a lot like Windows Plug-n-Play: You Plug it in and Play with it for a while and eventually it will work +)

    This morning I unplugged the gateway and plugged it into my laptop, started the Serial Monitor and got screens of data as sensors sent data to the Gateway. So, now I know for certain that the Gateway is working the USB is working, the cable is working... EVERYTHING is working but it isn't :)

    So I plug it back in the Vera and try to select the Serial Port; No Joy. I hit the Reload on Vera, click Develop Apps, Serial Port and VOILA, all of a sudden there is the configuration data for the port. Configure the port, Vera restarts and my sensor network runs again.

    Plug-n-Play. Once you understand this concept all is revealed to you :)

    I think its time to start working on the Ethernet Gateway


  • Contest Winner

    @clippermiami Your experiences are very similar to mine (although I do not have any sensors yet). My USB gateway sometimes refuses to be identified by the Vera. But I have noticed the LED behavior on the gateway and have seen that sometimes, it does not seem to boot properly. I suspect the power supply from the Vera USB port is totally sucky, so I have ordered a ethernet module and will probably go for that approach instead :)
    Btw, do you (or anybody else) know if it is supported to use DHCP for the ethernet GW? I intend only to use it for IP assignment. My router will map the GW MAC address to a static IP of my choice.


  • Admin

    @clippermiami
    Ha ha. sometimes you have to make a very special dance backward around Vera singing loudly while sacrificing a small arduino or similar to the Vera gods to get things working.

    @Anticimex
    Yes, but it will suck a lot of extra valuable flash. I disabled all DHCP in library to make it fit at all. 1.4 uses a few bytes less so you might squeeze it in now.


  • Contest Winner

    @hek Ah, I see. Well, for a GW, I suppose that once you got it working, there is no need to add extra features and sensors to it (I do not intend to anyway) but it is not a deal-breaker, just a convenience. I will start off on the 1.3 release just to get the stuff running, and then upgrade.


  • Hero Member

    @hek Ah yes, The Sacrifice of the Vera Virgins ... I think my problem was that I didn't wait until the Full Moon or something :-)


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.