Easy/Newbie PCB for MySensors


  • MySensors Evangelist

    @sundberg84 as I am not a soldering king... we will check the work and report back...... applied a bit more solder to the vout and we have beep 😉 now let's continue the work.
    Wow, 3,3 and 3,29v on the antenna. tnx.


  • Hardware Contributor

    @sincze no worries. Good luck.



  • Hi,
    I‘m new to MySensors and the Newbie PCB. At the weekend I build my first sensor but I had one Problem. I want to use battery powered sensors so I’m using the 3.3V battery booster. I’m have connected/soltered everything and the Arduino was runing fine. But the NRF24-Module wasn’t working. I cheked it and there was no voltage at the Vcc pin of the NRF24. Then I found out, the NRF24 is only powered if the battery jumper is closed. If the battery jumper is opened there is not voltage at the NRF24 module and also not at the 3.3 pin of the MysX pin out. Ist this correct?I thought the NRF24 is powered by the battery booster by default. Or did I get it wrong?


  • Mod

    @SolderNewbie of course you need to close that jumper since you are using batteries.


  • MySensors Evangelist

    @sundberg84 tnx.
    I looked at the FAQ and could not find an explaination how to use the pins TX/RX.

    The following is now on my build list, but maybe if I can use TX/RX pins it will free something...

    1. LED RX=A05
    2. LED TX=D02
    3. Relay_1=A00
    4. Relay_2=A01
    5. Relay_3=A04
    6. Temp_D03 (total of 4, resistor currently already soldered into the wire)
    7. Door_Switch=D05
    8. Leakage_Switch=D06

    I tested the sketch on a Arduino Nano and it is working, now I need to convert everything to the Easy/Newbie PCB. 😉



  • @gohan
    But i want to power the NRF24 with the battery booster and not directly with the batteries. Is this possible? The NRF24 modules is working with 1.9V than i have to replace the batteries. But with the battery booster i can drain the batteries down to 0.4 V each!


  • Mod

    I think I did once a little mod for that case: I shorted Vin and Vout where the radio voltage regulator would be.

    PS but I shorted REG and not BAT



  • @gohan Thanks for this hint!
    I put a jumper into Vo and Vi of the voltage regulator pins and shorten it, that's all! Not needed to shorten REG or BAT jumper! The Vi pin is connected to the Vo of the battery booster and the Vo of the voltage regulator pin is connected to Vcc of the NRF24 module.

    Maybe an idea for rev 10? Battery booster powered NRF24 module?


  • Hardware Contributor

    @SolderNewbie

    If the battery jumper is opened there is not voltage at the NRF24 module and also not at the 3.3 pin of the MysX pin out. Ist this correct?I thought the NRF24 is powered by the battery booster by default. Or did I get it wrong?

    This is correct because you dont want to feed 3.3v from the booster to the radio. The radio is very sensitive to noise (which will be the case with the booster) and since the radio can handle down to 1.9v the pcb is used like the description How?>Battery 3.3v @ https://www.openhardware.io/view/4/EasyNewbie-PCB-for-MySensors. This will feed the vattery voltage only (not from Booster) and therefore not give noise to the radio.

    As mentioned above by @gohan its possible but not recommended... unless you got some really good modules you will end up with a 2m range on your radio (or no connection at all)

    Maybe an idea for rev 10? Battery booster powered NRF24 module?

    This is why Rev 1 and 2 never made it... I have been trying this out since 2014 and it just doesnt work. You might get lucky with 1 or 2 modules that works (or pay alot for low noise boosters which isnt my thought with EasyPCB).

    I would instead suggest lowering BOD and/or change bootloader.


  • Hardware Contributor

    @sincze

    use the pins TX/RX

    what do you mean? You can find the pins on the MysX connector (bottom left on the PCB). Instructions on how to use the pins isnt my cup of tea. You need to google that or you have to look at the arduino homepage.

    There isnt anything to convert from nano to EasyPCB (except to find the right pins). The sketch will work just fine as it is.


  • Mod

    @sundberg84 my cheap alixpress booster and CDEbyte NRF24 worked fine on my solar powered outdoor sensor


  • Hardware Contributor

    @gohan as I said, I have been doing EasyPCB since 2014 and you might get lucky 😉

    You need a great booster and a great radio - this works, but as we all know this combination when shopping from china is pure luck.


  • Mod

    I had to do it because the supercap can go to lower than 1.9V, but I noticed it wasn't that bad, probably because I was generous on ceramic caps 😀


  • Hardware Contributor

    @gohan - trust me, I have tried all the caps there are on the booster. I also have now recently checked with a oscilloscope but I cant see any major difference (in less noise vs with or without 0,1-10uF cap). I must admit I have more test to do in booster - EasyPCB (cap) so any input is appreciated but im not sure a bigger cap equals less noise. A smaller cap can react quicker than a big one i think and with that it means you have to find a balance with response - capacity. If so, I can see with the booster I have (bad quality) varies a lot on noise, and with that means you should need a different cap on every booster (depending on the noise).


  • Mod

    I have a 10uF ceramic on both booster output and near nrf24 socket and it has been working well. For battery powered nodes I'm moving to LiFePo4 batteries that have no need for booster and voltage divider. Much less hassle.


  • Hardware Contributor

    @gohan - yea, just as I said above. Moving to another battery or lower BOD/change bootloader is one good way to avoid booster problems. Good to hear its working well for you - lets hope it continues that way.



  • @sundberg84 Thanks for clarification! Do you have any idea how long i can power a NRF24 module with two AA batteries until the voltage is to low?


  • Hardware Contributor

    @SolderNewbie - it depends on many factors, but one example I have 2xAA, Pro Mini (Led and Voltage reg removed), DHT22, Voltage divider (for battery measurment), booster and sending temp & humidity + battery status every 15min should last 1-1.5 years.


  • MySensors Evangelist

    @sundberg84 Got it. In the end it I did not have to use them.

    All devices I was looking for to use are working except for my Dallas Temp Sensors.
    The resistor is between the wires VCC and DATA in the connectors so not soldered on the board itself.

    I checked if pin header
    D3 had connection with D3 on the arduino (beep),
    GND with GND on the arduino (beep),
    VCC with VCC on the arduino (beep) at 4,7v.

    So the connector should be okay (no soldering error this time). If I connect the wire to the old Arduino nano the temp sensors are found... Connect them to the PCB.. Nothing found. Well must be something stupid I am missing here right?.

    To check D3, I made an RX tranmission Led attached and it flashed fine. So it should be okay.


  • Hardware Contributor

    @sincze - that sounds strange.
    Is it the same sensor or could the dallas sensor be broken?
    Can you see anything in the debug/serial? /(Sometimes you can see -127 and so).


  • MySensors Evangelist

    @sundberg84 Strange thing is.. If I unplug the temp cable from the PCB and plug it into the NANO the sketch detects the sensor. The exact same sketch on the mini says "0 sensors found" as I just print the number of sensors detected.
    For debugging purposes If I would solder the resistor on the PCB and I have a different temp sensor with resistor within the cabling. Would that hurt (double resistors) ?
    Would I have to look for a specific voltage between D3 and GND ?


  • Hardware Contributor

    @sincze - so it sounds like you have issues between pcb connector and A0 pin on the atmega328. You could try to do a continuitytest between that - and check soldering job on the MysX connector and on the back on the pro mini (A0)

    0_1510823476205_upload-31f0d5a6-9fc8-42a1-bf58-2a6d7f490457


  • MySensors Evangelist

    @sundberg84 Just for the check A0 or D3 (temp sensor)?
    As A0 is working, I have a relais attached to it. 😉


  • Hardware Contributor

    @sincze sorry - my misstake, D3 offcourse. You can do if from D3 on the MysX connector to D3 on the atmega chip. D3 on the cjip is the upper left pin on the image.

    0_1510831452813_upload-0d859cac-e93c-40ad-9f2f-f68ddcd6fdeb


  • MySensors Evangelist

    @sundberg84 yes, I have a 'beep' pffffff would a double resistor hurt ?? 1 on pcb the other one in the cable?
    I tried connecting it directly to pin 3 on the arduino, no detection, I tried replacing the resistor. nothing. I tried a different temp sensors.. No detection. I moved the new temp sensor to the nano... detected.
    I tried an empty Dallas temp only sketch on the mini... no detection. Well Now I'm lost 😉



  • @sincze Can you possibly send pictures with how you have it connected both on the nano and on the mini? I am thinking that it is something obvious that is being missed.


  • Hardware Contributor

    @sincze - and you use the right power source on the PCB? (VCC = 5v and 3.3v = Well... 3.3v) Please send pictures of both setup as mentioned.



  • Hi Sundberg84,

    I have some v8 and now enough time for playing.
    I setup with v3.3 2xAA, booster, NRF24, simple door sensor or DHT.
    1-2 week and the batteries are discharged, I hear little buzz from the mini or other components.
    This is the 2nd built where I meet this problem.
    Do you have any idea what component is the failed ?
    thanks
    Barna


  • Mod

    Did you remove the regulator and LED from the pro mini? Have you tried a different booster?


  • Hardware Contributor

    @Barna as @gohan said I suspect the booster as well. A small buzz is normally from that hardware.
    Also did you implement sleep() ?



  • @sundberg84 this is not normal buzz, stronger than before.
    I have used this source only: https://www.ebay.com/itm/mini-DC-DC-0-8-3-3V-to-DC-3-3V-Step-UP-Boost-Power-Module-For-Breadboard-Arduino-/281556288481?hash=item418e1003e1
    which another part could make the buzz ?
    yes, I use sleep
    sleep(1, CHANGE, SLEEP_TIME); SLEEP_TIME is 900000 , but the node does not wake up and send the battery status, only when door sensor changes.
    No, I have not removed the led and regulator, this is the testing period only 🙂


  • Mod

    Those draw quite some energy, you'd better remove them and see from there



  • @Barna What if you used a setup like this:
    0_1510936047717_upload-c0db2caa-660d-4a18-a9a9-c9c2cf96935c
    The 3volt tap can be used to power the arduino, and the DHT can be run from the 4.5v. With that you wouldn't need the step up booster.


  • MySensors Evangelist

    @sundberg84 @dbemowsk Thank you guys for still trying to help me. I almost gave up on using a Dallas Termp sensor o n a pro mini. As said I even tried connecting the temp sensor directly to the pins with same results. If I connect the pins to my nano, it is being detected and transmitting temp values. I even used a different sketch.. Just for the temp sensor. link found_here. Changed it to use Pin 3 ofcourse. I even connected the whole thing to D2 (resistor back in the wires)... without being succesful either.

    0_1510938558966_Dallas Not Detected.png



  • @sincze Are you sure you sure you got correct power on the GND and VCC pins on the MySX connector?


  • MySensors Evangelist

    @dbemowsk I had those thoughts as well.
    0_1510946155798_Dallas Voltage.png
    The voltage should be okay. I can solder a new Arduino Pro Mini and see if that one wants to work with me 😉


  • Hardware Contributor

    Dallas temp sensors needs 3.3v VCC if I remember right. Not 5v.


  • MySensors Evangelist

    @sundberg84 haha yes i was wondering that myself so tried it connecting it to 3,3v as well. However on the 5v nano working just fine. Technical specs tell me: Power supply range is 3.0V to 5.5V
    also mysensors link
    Pretty strange huh.


  • Hardware Contributor

    @sincze my mistake. Really strange this... Should work just fine. Can you upload a better resolution picture of your hardware and the sketch you are using?



  • @sincze I have 10 of these DS18B20s strung over approximately 12m monitoring all rooms on both floors of my house and two side lofts, all running on 3.22v from a Pro-Mini. Never have skipped a beat, reporting every 5 minutes, well, aside from a telephone socket which pins went walkabout (the chips are crimped to RJ11s).
    There is something not right with the physical arrangement if you can get the same circuit to report at 5v...


  • MySensors Evangelist

    @sundberg84 I just soldered a myself a new out of the box pro mini using the same sketch..

    10246 TSF:MSG:SEND,8-8-25-0,s=0,c=1,t=0,pt=7,l=5,sg=0,ft=4,st=OK:21.0
    250560 TSF:MSG:SEND,8-8-25-0,s=0,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=OK:21.1
    255019 TSF:MSG:SEND,8-8-25-0,s=0,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=OK:22.3
    259476 TSF:MSG:SEND,8-8-25-0,s=0,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=OK:23.8
    263934 TSF:MSG:SEND,8-8-25-0,s=0,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=OK:25.3
    268393 TSF:MSG:SEND,8-8-25-0,s=0,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=OK:26.5
    272851 TSF:MSG:SEND,8-8-25-0,s=0,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=OK:27.6
    277310 TSF:MSG:SEND,8-8-25-0,s=0,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=OK:28.1
    281768 TSF:MSG:SEND,8-8-25-0,s=0,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=OK:28.4
    290677 TSF:MSG:SEND,8-8-25-0,s=0,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=OK:28.3
    295136 TSF:MSG:SEND,8-8-25-0,s=0,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=OK:28.1
    299594 TSF:MSG:SEND,8-8-25-0,s=0,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=OK:27.8
    304053 TSF:MSG:SEND,8-8-25-0,s=0,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=OK:27.6
    308511 TSF:MSG:SEND,8-8-25-0,s=0,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=OK:27.3
    312970 TSF:MSG:SEND,8-8-25-0,s=0,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=OK:27.1
    317428 TSF:MSG:SEND,8-8-25-0,s=0,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=OK:26.8
    321887 TSF:MSG:SEND,8-8-25-0,s=0,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=OK:26.6
    326345 TSF:MSG:SEND,8-8-25-0,s=0,c=1,t=0,pt=7,l=5,sg=0,ft=0,st=OK:26.4

    Victory... 🙂


  • Mod

    Was the pro mini defective or just the pin you were using?


  • MySensors Evangelist

    @gohan Don't know. Pin3 could be used to drive the led tx without problems. It only did not work with the temp sensors. I moved the temp sensor to d2.... modified the sketch and it did not work as well. and d2 was driveing rx led. So well root cause unknown... solution: solder a new pro mini and keep the other one for different purpose.



  • @sincze Did you use D2+D3 on all the same devices?


  • Mod

    I'd try the other digital pins too


  • MySensors Evangelist

    @zboblamont @gohan The Sensor with the replaced Pro Mini is in production now ;-). I'll start soldering a new Easy/Newbie PCB, because once you know how to do it... it is Easy and test the individual pins with a door/window sensor.



  • Hi Sundberg84,
    What could you advise for battery powering (remove led and regulator too) if I would like to use Mini 5V and measure the battery level too ?
    thx

    Barna


  • Hardware Contributor

    @Barna the 5v pro mini are running a 16mhz crystal as default and this needs higher voltage to be stable compred to 8mhz (3.3v pro mini).

    I have never tried this so can't give much advice but I would probably take the effort of reprogramming the fuses and bootloader to a internal 1mhz and run the hardware as that (the hardware is the same on 5v except the regulator and crystal )


  • Mod

    @Barna why do you want to use a 5v arduino?




  • Hardware Contributor

    @barna lower noice is better but I can not confirm this module is better. You have to try. Yes you can connect this to EasyPCB just like the first one.



  • Hi All!

    Could someone suggest me an elegant way to extend the mysx connector? SO i would like to multiple the A4 A5 pins onto another prototype board to use more I2C devices....


  • Hardware Contributor

    @tommas just add a wire on the back side to the prototyping area ? You could design a MysX daughter board as well 😉



  • @sundberg84

    Unofrtunately i havent got the skills and free time for a daughter board.:(. But doesnt have someone else a daughterboard?:)



  • @sundberg84

    Or have you got any suggestion expansion board for arduino mini pro ? Something like this: arduino-pro-mini-undershield (but it can not buy on ebay)


  • Hardware Contributor

    @tommas how about a wire to the prototyping area ?



  • @tommas you could easily take a piece of prototyping PCB like this and create your own daughter/prototyping board if you need more space than the prototyping area has.
    0_1512845129504_6f4f47c7-736c-4804-84f2-72b392d1e4fe-image.png
    Use a set of connectors like this to connect to the MysX connector on the easy newbie board.
    0_1512845514755_20e6995e-fad7-4318-93c3-98f5f0308046-image.png


  • Hardware Contributor

    I have plans for MYSX connector daughter boards, maybe if you tell me more about what you are planning to use I can adapt.



  • Hi community!
    i just got to fiddle around with my new newbie pcb and i ran into some problems.
    I am already quite familiar with mysensors as i have built quite a couple of different nodes which are working very well (all on bread boards or selfmade pcb boards)
    No i wanted to step up a bit and bought the newbie pcb boards.
    I want to have a battery powered setup. So i did solder all the parts on the board. checked my wiring many times and also checked all components. I even did check the whole pcb board if every line is ok with a multimeter.

    So my problem is:
    all the time i debug my node (mockup sketch) with the Arduino IDE powered by battery, stable power source etc i end up having the error TSP failed.

    when i leave my set up as is (i solders headers to the board to conveniently change the components ) and only power the NRF24 seperatly i get no errors. So it must be something with my power ?
    but i don't get it where exactly my problem lies.
    Could somebody help me?


  • Hardware Contributor

    @helvetian - hi, sure we can help!
    But it would be much easier if you described your hardware setup (picture?) and logs.
    The EasyPCB is versatile so you can use it in many ways, but a wrong combination can make it not work.
    Do you use a DC-DC booster? Batteries? Which jumpters did you solder? And so on...

    Did you by any chance connect both batteries and ftdi Vcc at the same time?



  • thx for your fast reply. i'm in the train right now. so i can't provide you now with any pics. as soon as possible i will do that!

    I am using a battery booster (as it seems the same as you use), i have the battery jumpers connected, all the resistors and caps for the battery measurement.
    It is just wired that it functions while the nrf24 is powered separately. maybe i got some bad radios?
    One more question: the cap just below the booster. is this necessary to reduce the noice for the radio? might that help and if yes what size do you recommend? i didn't solder any cap yet there.

    "Did you by any chance connect both batteries and ftdi Vcc at the same time?"
    Yes! I did try this as well. Same results...
    I should also mention i got my Arduino Pro mini battery powered hacked. So no more LED and Voltage regulator. But then again i also tried it with a untouched one.


  • Mod

    I am using 2 10uF ceramic caps both on booster and radio side, so I strongly recommend to get a bunch of those as they are working better than the electrolics and can be used in many ways.


  • Hardware Contributor

    @helvetian - good, sounds like a good start.
    If you have a booster + battery jumper in place this powers the radio separately. The most critical capacitor is the one close to VCC/GND on the Nrf24 radio. What value do you use here? Sometimes it helps to try higher values. I use 4,7 in normal cases but sometimes I either replace it or add in parallel a 47uF as well.

    maybe i got some bad radios?

    This is not uncommon... noice from the booster (also common) combined with a bad radio might do this.

    One more question: the cap just below the booster. is this necessary to reduce the noice for the radio?

    Yes and No - I dont have any hard evidence (there are caps on the booster itself) but I have had good results with a 0,1 cheramic cap for a node that didnt work. It doesnt hurt to add.

    "Did you by any chance connect both batteries and ftdi Vcc at the same time?"
    Yes! I did try this as well. Same results...

    Dont do this - only 1 Vcc allowed 🙂

    When you have the time, upload a picture - it will probably help us more to help you.



  • here are some pics form my pcb board!

    0_1516654067507_20180122_213519.jpg 0_1516654074837_20180122_213527.jpg 0_1516654086429_20180122_213538.jpg


  • Hardware Contributor

    @helvetian looks good! Nice work.
    I would start by soldering in/change capacitor on the radio and booster as mentioned. Try some other radio of you have. I have never connected the jumper for irq so just to test of nothing else works you can de-solder the irq jumper.



  • ok. thanks for the tips and your promt assistance! such a great community!
    i will try to experiment with some caps.
    i tested already a couple of different radios. but maybe i will get once a decent one which will work


  • Mod



  • @gohan
    just bought them on ali. What would you recommend in the meantime till they arrive here in snowy switzerland? i got a assortement of electrolyt caps.
    i got a bunch of 0.1uf ceramics. could i just solder(or test it on a breadboard) 10 of them to try out?


  • Mod

    try adding first one on the booster and see what happens



  • just a quick update.

    i ran some more tests with different radios and a 10uf electroltyte cap on the booster. And some different batteries.
    Heureka! It works. For now. It is running now with a 3.7v lipo battery without the voltage regulator. Does anybody know if this is safe in the long run?


  • Mod

    I wouldn't do it if I were you. You are going to fry the radio


  • Hardware Contributor

    If you bypassed the booster and that works it seems like you have a booster which generates alot of noice. Try bypassing it with 2xaa and see what happens.



  • @sundberg84 do you experience the same thing when you are using boosters? Some are better than other even tough they are the same model? Same with the radios?


  • Hardware Contributor

    @helvetian correct. I can buy a batch with 10 boosters and some works and some don't. Most can work with the right capacitors as support but a few was just impossible.


  • Mod

    @helvetian when dealing with cheap Chinese stuff, you always have to consider that you may have got a poor quality product and because of this I also bought LiFePo4 batteries that run at 3.3v so no regulator needed making it easy to figure out if it is a power issue or else



  • Thanks for clarifications

    Awesome forum!


  • Hardware Contributor

    @helvetian - just so you dont miss this. A Atmega328 (Pro mini if you are using EasyPCB) can be run without a booster by reprogramming the fuses/bootloader. This is more advanced but possible. Then you can run the pro mini with a 8mhz or 1mhz internal clock down to the radio minimum 1.9v. This is a better option compared to boosters but harder to achieve.


  • Hardware Contributor

    @sundberg84 said in Easy/Newbie PCB for MySensors:

    @helvetian - just so you dont miss this. A Atmega328 (Pro mini if you are using EasyPCB) can be run without a booster by reprogramming the fuses/bootloader. This is more advanced but possible. Then you can run the pro mini with a 8mhz or 1mhz internal clock down to the radio minimum 1.9v. This is a better option compared to boosters but harder to achieve.

    No it is not "hard". You just need to copy files in a directory, edit a text file and flash ISP sketch on a nano or uno bard. Easier than dealing with unreliable boosters 😛


  • Hardware Contributor

    @nca78 ... can be discussed. Wiring needs to be right. It's not hard when you know what to do but it's harder compared to a working booster.


  • Mod

    This post is deleted!

  • Hardware Contributor

    @gohan - sorry, didnt understand?



  • I've just built a few nodes using the EasyPCB Rev 9 RFM69 Edition and I can confirm it lives up to its name - build takes only 15-20 mins, and node works first time because there is no chance of incorrectly wiring the radio. Thanks @sundberg84!

    The PCB fits nicely along with 1 or 2 AA batteries into the 100x60x25 project boxes available on eBay for about $1 each:

    Easy PCB in 100x60x25 project box

    (AA battery holder is actually about 1.5mm too long to fit - I've cut off the non-spring end of the holder, and the positive wire is held by tension between the +ve battery terminal and the side of the case. Ugly, but fine for nodes that don't get moved around. White tape is to prevent antenna from shorting against the top of the radio module.)

    I have a couple of observations that might be worth considering to make the next revision even better:

    • According to the MySX specification, MySX header pin 10 should be connected to Arduino pin D4, not D2 (which is already used for the radio)?
    • It would be handy to have a bit more space between the voltage booster and the adjacent cap - boosters with pre-soldered right-angle headers don't fit without hiting the adjacent cap (see photo). You could free up some space for this by mounting the battery measurement resistors vertically. (There is a risk that this might cause the voltage divider circuit to pick up noise from the adjacent booster; which might cause a bit of random fluctuation in the battery voltage readings. I suppose you'd need to do some tests to see if this is actually an issue.)

    photo showing booster hitting adjacent cap

    • I put a few layers of insulating tape under the RFM69 so that it sits about 0.5mm clear of the PCB, to make it easier to desolder if the need ever arises (see photo). It would be nice if there were holes in the RFM69 pads so that it could optionally be mounted via 2mm male/female headers. You'd need to make a small adjustment to the antenna length if actually using headers, but otherwise I don't think this would affect the radio's performance.

    photo showing tape under radio module

    • EDIT: You can surface-solder 2mm headers to the existing pads, but it ain't pretty:

    RFM69 mounted on 2mm headers

    • You can mount a DS18B20 in the prototyping area!! (requires wire soldered under PCB to arduino input pin)

    photo of DS18B20 mounted in prototyping area

    • I think the 4k7 pullup resistor for DHTxx/DS18B20 temperature sensors should be on any pin other than D3. The only (easy-to-use) hardware interrupts on the ATMega328P are D2 and D3, and D2 is already used for the radio, so D3 should be reserved for sensors that require an interrupt (e.g. motion sensors, buttons, switches).
    • In fact, the space taken up by the pullup resistor might be better used as a second prototyping area. If you bring out some arduino IO pins to this area, you could actually connect a pullup resistor to any of those IO pins. It would also be good to bring out some of the IO pins that aren't already brought out on the MySX header. Suggested layout (apologies for literally-back-of-an-envelope sketch):

    sketch of suggested prototyping area layout

    Hope that's all useful / constructive.

    Thanks again for designing this awesome PCB!



  • @wes Really like those 3.5mm jacks you used for the temp probes. Did you get those from ebay too?



  • @dbemowsk said in Easy/Newbie PCB for MySensors:

    @wes Really like those 3.5mm jacks you used for the temp probes. Did you get those from ebay too?

    Yes - sockets / plugs

    The plugs were not great quality - screw threads were mangled so it was very difficult to screw on the backshells. I'd go for slightly more expensive ones next time. The sockets were fine.

    EDIT: NB the tip and ring contacts on the socket will momentarily short out as the plug is inserted, so it's really important to wire the plugs/sockets so that this doesn't short out VCC/Ground, e.g.

    • Tip: VCC
    • Ring: Data
    • Sleeve: Ground

    Which will cause VCC/Data to short out when the plug is inserted, which is fine.


  • Hardware Contributor

    @wes said in Easy/Newbie PCB for MySensors:

    • According to the MySX specification, MySX header pin 10 should be connected to Arduino pin D4, not D2 (which is already used for the radio).

    I think you are mixing up the MYSX pin numbering and the Arduino pin numbers.
    Fourth digital pin of the MYSX connector ("D4") is clearly stated as beeing an interrupt pin, so on and ATMega328 based board it cannot be any other pin than D2 or D3.


  • Hardware Contributor

    @wes - Woaw! Thanks a million man for the great and clear feedback!
    Its a great feedback on several points which I'm going to take into Rev 10!
    And nice looking node you have built - very clean and professional!

    • MysX, as already mentioned I think pin 10 it should be a D2 + D3. If you check out one of the MysX authors boards schematics it the same.

    It would be handy to have a bit more space between the voltage booster and the adjacent cap - boosters

    I have had this on my mind before but the booster I designed it for, its pins were mounted the other way around which worked out great. This is the second time I hear that part of the board needs more space and maybe I could move the voltage divider (different reasons) but I think it might be a good idea.

    I put a few layers of insulating tape under the RFM69

    Its a great tip - I use ESP-07 for some stuff and do the same! Easy to desolder if needed.

    It would be nice if there were holes in the RFM69 pads

    Consider it done.

    I think the 4k7 pullup resistor for DHTxx/DS18B20 temperature sensors should be on any pin other than D3...

    Pure logic - I agree, consider it done.

    In fact, the space taken up by the pullup resistor

    Im thinking maybe I should move the resistors for battery measurment under the Arduino Pro Mini and re-use this area as you described. Thoughs?



  • @sundberg84 said in Easy/Newbie PCB for MySensors:

    the booster I designed it for, its pins were mounted the other way around which worked out great.

    Perhaps an even better solution would be to provide two sets of holes for the booster, so that it can fit in the designated space regardless of which way round its pins are.

    @sundberg84 said in Easy/Newbie PCB for MySensors:

    Im thinking maybe I should move the resistors for battery measurment under the Arduino Pro Mini

    Great idea! The only consideration is clearance if soldering the Arduino directly to the PCB, but resistors should be ok - the black plastic spacers on the header pins are 2.3mm high, and typical resistors are only 2.2mm in diameter.

    You could even get away with putting caps under the Arduino, if you allow enough space for the them to be laid on their side if soldering the Arduino directly to the PCB. My 0.1uF electrolytics are 4.1mm diameter, so a directly soldered Arduino would have to sit about 2mm higher than normal. Or you could use tantalum or polymer capacitors, which should be less than 2.3mm high if laid on their side (but more expensive than electrolytics).

    Some further thoughts I had overnight:

    • Could you please post a JPG/PNG of the schematic in the design files section? (The schematic on the description page is a bit too small to read. Thanks!)
    • You could save some space by changing the REG/BAT selection from jumpers to solder bridges, which can be squeezed into a lot more places on the PCB, especially on the back. However, the REG/BAT headers are useful both as a power switch and a great place to connect a multimeter/ammeter to measure the node's current draw, so I'd be a bit sad if you did this.
    • There's enough space under the RFM69 (on the back of the PCB) to mount a CR16xx battery holder. Or if you relocate the adjacent caps, there would be space for a CR20xx battery (which are cheaper, higher capacity, and easier to find).
    • If you were to make the whole right hand side of the board a prototyping area (i.e. clear of components), it would be exactly the right size to mount a 1xAAA battery holder.
    • If you do bring Arduino IO pins out to the prototyping area(s), it would be really useful to put solder bridges in the traces (if space permits), or at least space the traces to make it easy to cut any that aren't wanted.
    • A PCB trace antenna would be really cool!

    I know that's quite a wishlist, and not all those ideas are compatible with each other, or the Nrf24l01+ version of the PCB, but I hope that provides some useful inspiration nonetheless.

    Thanks again @sundberg84 👍


  • Mod

    @wes pcb antenna is going to be a challenge since rfm69 come with 3 possible frequencies


  • Hardware Contributor

    @wes

    Im thinking maybe I should move the resistors for battery measurment under the Arduino Pro Mini

    Great idea! The only consideration is clearance if soldering the Arduino directly to the PCB, but resistors should be ok - the black plastic spacers on the header pins are 2.3mm high, and typical resistors are only 2.2mm in diameter.

    Maybe a better idea is to include a SMD voltage divider on the back for advanced users and not make the current voltage divider harder to use (by putting it under the pro mini)

    • Could you please post a JPG/PNG of the schematic in the design files section? (The schematic on the description page is a bit too small to read. Thanks!)

    I have posted for RFM Rev9. Nrf I will post as soon as Rev 10 is developed (Using Kicad now).

    • You could save some space by changing the REG/BAT selection from jumpers to solder bridges, which can be squeezed into a lot more places on the PCB, especially on the back. However, the REG/BAT headers are useful both as a power switch and a great place to connect a multimeter/ammeter to measure the node's current draw, so I'd be a bit sad if you did this.
    • I will not use any smaller / smd components on the top side. All main functions have to be 2.54mm/legs.
    • There's enough space under the RFM69 (on the back of the PCB) to mount a CR16xx battery holder. Or if you relocate the adjacent caps, there would be space for a CR20xx battery (which are cheaper, higher capacity, and easier to find).
      If you were to make the whole right hand side of the board a prototyping area (i.e. clear of components), it would be exactly the right size to mount a 1xAAA battery holder.

    I will consider this... or maybe we can do some sort of pins for this on the prototyping area and make a tutorial.

    If you do bring Arduino IO pins out to the prototyping area(s), it would be really useful to put solder bridges in the traces (if space permits), or at least space the traces to make it easy to cut any that aren't wanted.

    I will consider this, but as mentioned I will not use smd bridges so space might be a problem.

    A PCB trace antenna would be really cool!



  • @gohan said in Easy/Newbie PCB for MySensors:

    @wes pcb antenna is going to be a challenge since rfm69 come with 3 possible frequencies

    Of course (doh)

    @sundberg84 said in Easy/Newbie PCB for MySensors:

    I will not use any smaller / smd components on the top side. All main functions have to be 2.54mm/legs.

    Sure thing; that's a good philosophy. To be clear, by solder bridges I meant two pads separated by a very small gap that can be bridged with a bit of solder, aka solderable jumpers:

    solderable jumpers photo

    solderable jumpers pad designs

    (as opposed to SMD jumpers)

    For your enjoyment, here 's a timelapse of a node I built today:

    Building a MySensors EasyPCB Sensor - timelapse – 02:25
    — Li-Wen Yip


  • Hardware Contributor

    @wes - so cool man! Thanks!
    I have had in my mind for ages to do some sort of instruction / build video to be even more Newbie friendly. Is it ok if I link to this as a good build example on openhardware?

    About the solder-pads - I know about them - use them in other projects. Maybe I'm a bit over-concerned about this - I will have it in my mind as a solution.

    Some initial schematics today.

    0_1517745244265_35197432-65f4-4a36-b101-f834166c5384-image.png



  • @sundberg84 said in Easy/Newbie PCB for MySensors:

    Is it ok if I link to this as a good build example on openhardware?

    Of course. I can share the raw JPG images too if you want.

    NB I used capacitor legs as header pins on the RFM69 because the proper header pins I ordered from eBay are still in the mail.


  • Hardware Contributor

    @wes - you might have inspired me to try a instructions video myself 🙂 I appreciate the jpg offer and thanks for letting me use it as a good example. Great example on how to build modular to be able to change or re-use hardware.


  • Hardware Contributor

    Im locking this thread (due to multiple threads). Please use this to discuss. https://forum.mysensors.org/topic/2740/easy-newbie-pcb-for-mysensors


Locked
 

351
Online

8.2k
Users

9.0k
Topics

95.9k
Posts