Node send fail - No return ack?



  • I built several temp sensors and a ENC28J60 nano gateway last year and they all worked pretty good. I had to put the project down for the summer and I picked it back up last week.

    I noticed that MySensors had changed to 1.5 so I set everything back up and reflashed my gateway and a temp sensor to new version. I also completely restarted my Vera so I could completely start over.

    Nodes send to gateway, gateway sends to Vera. Seems to all work except my nodes (I've tried several on static node ids and auto) all seems to st=fail. Every blue moon it will give a st=ok. The gateway is receiving the data and posting it to Vera but it does not seem to be sending back an ack to the node. Any idea what is going on here?

    From node:

    send: 105-105-0-0 s=255,c=0,t=17,pt=0,l=5,sg=0,st=fail:1.5.1
    send: 105-105-0-0 s=255,c=3,t=6,pt=1,l=1,sg=0,st=fail:0
    sensor started, id=105, parent=0, distance=1
    send: 105-105-0-0 s=255,c=3,t=11,pt=0,l=18,sg=0,st=fail:Temperature Sensor
    send: 105-105-0-0 s=255,c=3,t=12,pt=0,l=3,sg=0,st=fail:1.1
    send: 105-105-0-0 s=0,c=0,t=6,pt=0,l=0,sg=0,st=fail:
    send: 105-105-0-0 s=1,c=0,t=6,pt=0,l=0,sg=0,st=fail:
    find parent
    send: 105-105-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,st=bc:
    send: 105-105-0-0 s=0,c=1,t=0,pt=7,l=5,sg=0,st=fail:22.5
    send: 105-105-0-0 s=1,c=1,t=0,pt=7,l=5,sg=0,st=fail:21.7
    send: 105-105-0-0 s=1,c=1,t=0,pt=7,l=5,sg=0,st=fail:21.6
    

    From gateway:

    0;0;3;0;9;gateway started, id=0, parent=0, distance=0
    0;0;3;0;9;read: 105-105-0 s=1,c=1,t=0,pt=7,l=5,sg=0:22.1
    105;1;1;0;0;22.1
    0;0;3;0;9;read: 105-105-0 s=1,c=1,t=0,pt=7,l=5,sg=0:22.0
    105;1;1;0;0;22.0
    0;0;3;0;9;read: 105-105-0 s=1,c=1,t=0,pt=7,l=5,sg=0:22.1
    105;1;1;0;0;22.1
    0;0;3;0;9;read: 105-105-0 s=1,c=1,t=0,pt=7,l=5,sg=0:22.0
    105;1;1;0;0;22.0
    

    These were not taken at the exact same time but it should give an idea of what is going on. I'm sure it is something simple I am missing from being out of the loop so long.

    I thought I had a problem with the gateway so I changed out the nano and the antenna. Nothing changed.

    Thank you for any help.



  • I have almost the same.
    In my node , I have a serie for a time, message are received by GW, but the ack is not sent properly... It's always the same child with the problem. Sometimes, the child 3 works, sometimes not... I don't see why this one !!!! and most of the time everything works !

    send: 102-102-151-0 s=1,c=1,t=0,pt=7,l=5,sg=0,st=ok:7.0
    Humidity: 99.90
    send: 102-102-151-0 s=0,c=1,t=1,pt=7,l=5,sg=0,st=ok:99.9
    send: 102-102-151-0 s=9,c=1,t=23,pt=3,l=2,sg=0,st=ok:1
    send: 102-102-151-0 s=7,c=1,t=24,pt=7,l=5,sg=0,st=ok:3910242.0
    send: 102-102-151-0 s=2,c=1,t=8,pt=7,l=5,sg=0,st=ok:12.1
    vitesse moy: 12.12
    vitesse max(rafale): 23.91
    send: 102-102-151-0 s=3,c=1,t=9,pt=7,l=5,sg=0,st=fail:23.9
    send: 102-102-151-0 s=8,c=1,t=25,pt=7,l=5,sg=0,st=ok:0.0
     Quantite pluie temporaire de l'heure: 0.00```

Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.