Deleted device from UI7, now won't add anymore -- RESOLVED



  • Hi everyone!

    I have been playing around with mySensors and built a few nodes.

    Recently, I have built an irrigation controller, with multiplexer rather than shift register and running on an Arduino Nano. After a few tests, I decided to update the device type to use SPRINKLERS. This is when things started going wrong.

    So right now, I have removed all the Arduino devices from my Vera, and also cleaned up any reference to "Arduino" from the user data using commands such as

    http://vera_ip:3480/data_request?id=device&action=delete&device=999
    

    Once I had a clean slate to start from (or so I thought), I uploaded all the device files again. Here is the content

    -rw-r--r--    1 root     root             0 May 27 10:27 va-install.sh
    -rw-r--r--    1 root     root          1685 May 27 10:26 D_Arduino1.json.lzo
    -rw-r--r--    1 root     root           575 May 27 10:26 D_Arduino1.xml.lzo
    -rw-r--r--    1 root     root          1152 May 27 10:26 D_ArduinoNode1.json.lzo
    -rw-r--r--    1 root     root           578 May 27 10:26 S_Arduino.xml.lzo
    -rw-r--r--    1 root     root           561 May 27 10:26 S_ArduinoNode.xml.lzo
    -rw-r--r--    1 root     root         12156 May 27 10:26 L_Arduino.lua.lzo
    -rw-r--r--    1 root     root           473 May 27 10:26 D_ArduinoNode1.xml.lzo
    -rw-r--r--    1 root     root          1892 May 27 10:26 D_ArduinoRelay1.json.lzo
    -rw-r--r--    1 root     root           485 May 27 10:26 D_ArduinoRelay1.xml.lzo
    -rw-r--r--    1 root     root          1859 May 27 10:26 I_Arduino1.xml.lzo
    

    Then I tried creating the Arduino device by following the instructions; specify the device file and click create.

    Current status shows the adruino device in the user data, but the device doesn't show up on the device list in UI7 and it is not possible to configure it. Here is how it appears in the user data.

    <device id="188" name="" device_type="D_Arduino1.xml" room="0" id_parent="0" embedded="0" disabled="0" device_file="" device_json="" impl_file="" manufacturer="" model="" altid="" ip="" mac="" time_created="1464357546">
    <states/>
    </device>
    

    Solved! Documenting here in case anyone needs it
    I created a support request to get some help from Vera Controls on this. They were very responsive and provided the missing step that allowed me to re-create the device in no time.

    Here is their answer:
    In order to make again the Arduino to work properly with our system, you’ll have to the following steps:

    1. Connect to the Vera’s web interface, then go to Apps>Develop Apps>Test Luup code (Lua) and run the following code, in order to delete all the arduino files:
    os.execute("rm -rf /etc/cmh-ludl/*Arduino*")
    
    1. Then upload again the files and configure again the Arduino.
      Also to view to source code of a file that is on your Vera controller, you’ll need to use the following local request :
    Vera_IP/cgi-bin/cmh/view_upnp_file.sh?file=xxx
    

    For example:

    Vera_IP/cgi-bin/cmh/view_upnp_file.sh?file=D_Arduino1.xml.lzo
    

    I would like to thank them for having been so quick to respond and would recommend their product as the back end automation workhorse on any hybrid mySensors/Z-Wave home automation solution as their platform has a lot of potential for expansion through custom plugins.


  • Admin

    In UI5 it sometimes helped to physically restart the Vera box to get rid of (hiddenly cached) things. Not sure if that still is the case.



  • Thank you for the suggestion. I tried, but no luck.

    I opened a ticket with Vera to see if they can help. Next thing I might try would be to remove the device definition files and re-upload, but I guess the issue is buried deep down somewhere and this would be like hitting the water with a sword trying to catch a fish.



  • This post is deleted!


  • I had the same problem.
    I deleted the (child) sensors, in order to recreate them with the latest version (2.0)

    When I tried to include them again they where not found.
    I found in the log (http://<vera-ip>/cgi-bin/cmh/log.sh?Device=LuaUPnP) that the devices where still there.
    In ALTUI I found the devices, removed them from there.
    After that I could include the sensors again.

    I am on a new Vera Plus 1.7.2138


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.