installing node-red and node-red-contrib-mysensors



  • Hey there,

    I have a problem installing node-red and the mysensors contribution from npm. I installed node-red like this http://nodered.org/docs/hardware/raspberrypi and it seems to work.

    Welcome to Node-RED
    ===================
    
    10 Aug 19:20:49 - [info] Node-RED version: v0.14.6
    10 Aug 19:20:49 - [info] Node.js  version: v4.4.5
    10 Aug 19:20:49 - [info] Linux 4.1.19-v7+ arm LE
    10 Aug 19:20:49 - [info] Loading palette nodes
    10 Aug 19:20:53 - [warn] ------------------------------------------------------
    10 Aug 19:20:53 - [warn] [serialport] Error: Module did not self-register.
    10 Aug 19:20:53 - [warn] ------------------------------------------------------
    10 Aug 19:20:53 - [info] Settings file  : /home/pi/.node-red/settings.js
    10 Aug 19:20:53 - [info] User directory : /home/pi/.node-red
    10 Aug 19:20:53 - [info] Flows file     : /home/pi/.node-red/flows_octopi.json
    10 Aug 19:20:53 - [info] Creating new flow file
    10 Aug 19:20:54 - [info] Starting flows
    10 Aug 19:20:54 - [info] Started flows
    10 Aug 19:20:54 - [info] Server now running at http://127.0.0.1:1880/
    

    Only that serialport error I don't know what's happening there. I wanted to install the contrib, but all it says is

    ~ $ npm install node-red-contrib-mysensors
    node-red-contrib-mysensors@0.7.6 node_modules/node-red-contrib-mysensors
    

    In node-red I don't see any nodes corresponding to mysensors (mysdecenc and mysencap, Hope anyone can help me to get this working.


  • Admin

    Did you restart node-red after you installed node-red-contrib-mysensors?

    Also, you could have a look in ~/.node-red/node-modules/ and see if node-red-contrib-mysensors exists there?

    About the serial port, there are probably some hints here: https://www.npmjs.com/package/node-red-node-serialport (I can't remember if I got the same error when I installed/upgraded node-red the last time)



  • Well thanks @tbowmo,

    I found my mistake: I have not been in the /.node-red/ directory. Now I have installed it correctly. Only problem left is with the serialport module. I allready tried to install the older version (0.0.5), but my node.js is to new. Also installing gcc6 and reinstalling serialport did not help. Do you maybe know where to find logs or anything?


  • Admin

    @Anduril

    I'm using node-red-node-serialport 0.1.2, works fine here..

    Did you install the serialport module globally, or locally in ~/.node-red ?

    How do you start node-red? If you're using pm2, then the logs are in ~/.pm2/logs.

    Otherwise, try to start it up from a terminal, just run node-red, it should use stdout for the logs then..



  • I installed it locally in /.node-red and tried different versions (newest 0.3.0, 0.2.1, 0.2.0 and now also 0.1.2) without success. Do you have yours installed globally? At the moment I start node-red from the terminal with node-red , but I get only the message as shown in post #1. Also google was not very helpful about this error message.

    edit: I also tried to install node-gyp to compile the serialnode, but didn't helped for the problem



  • Just to give an update: I wasn't able to register that plugin, so I started all over. I installed a fresh image and apt-get install nodered. After update and upgrade the version of nodejs was updated and with it came a script named update-nodejs-and-nodered with the very self-explanatory name. After that I had a new version of nodejs (needed for my controller) and a wokring node-red.


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.