Ethernet gateway 1.4 not responding to sensors during inclusionmode



  • I had everything working with 1.3 version and decided to upgrade to 1.4 for better quality of communication but I can't get it to work for 100%.

    When debugging I see that all messages from my humidity sensor are acknowledged by the gateway when resetting the sensor, meaning "st=ok". BUT.... almost all messages go wrong (st=fail) when I set the gateway into Inclusionmode!

    Sometimes some of the messages are OK meaning I have to restart the sensor about 10 times to get all the devices to show up in the gateway (in Vera). I didn't have this problem with 1.3, Only one restart was required to show all devices in Vera.

    While debugging I also found that the gateway is not receiving the messages from the sensor. In the function MyGateway::processRadioMessage() the if(process()) condition does not become TRUE. Meaning that in MySensor::process() the call to RF24::available(&pipe) is not returning TRUE, indicating no messages are waiting to be processed.

    Can someone please explain to me why there is a difference between inclusionmode and "normal mode"? As soon as the inclusionmode is over ALL messages are received and acknowledged again....

    (I have caps on all radios, tried with different PA-levels, different radios, exchanged the RF24 library against the one from 1.3 in both sensor and gateway, wall warts on both sensor and gateway, using the ENC-device etc.)



  • A little but oh so important update:
    I come to think of that I hadn't tried with a hardware inclusion-button yet. So I just tested that and now it's working perfectly!

    Up till now I started inclusionmode with the Start button on the Vera-gateway device. Clearly something is wrong when doing this.

    @hek: you maybe can find some time to look into the code for this?


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.