!TSM:FPAR:FAIL, standalone 328p + Nrf24L01+



  • Hi all!
    First, thanks all for this great project! So fun tinkering with electronics and programming!
    I have been running about 10 nodes for almost 2 years now, they are based on Pro Mini boards and running great in a mixed environment with versions from 1.4 to 2.0.

    Now I would like to do my own nodes from scratch, based on a bare Atmega328p-pu instead running at 3.3V, 8Mhz internal clock powered by 2xAA inspired by the "My Slim 2xAA Node" here on the forum.

    This is what I have done:

    I have changed fuses so I can run them on 3.3V @8Mhz internal clock with no BOD. (LFUSE: 0xE2 ,HFUSE: 0xDA ,EFUSE 0x07 (or 0xFF). And I have wrote a new bootloader as described here - Minimal setup, https://www.arduino.cc/en/Tutorial/ArduinoToBreadboard

    It seems its running ok standalone with 3.3 power supply and without any crystal, and I can upload mysensors sketches via serial interface and so on. The radio is connected, and an extra 10uF capacitor is connected on the radio.

    But now the trouble begins..
    When it starts up it inits the radio and try to connect but it doesn't seem to speak with the gateway as I get the following error when debugging:
    0_1474633292986_Skärmklipp_standalone.PNG

    If I put the processor in at spare UNO and moves the radio to that board it starts up ok and can connect to the gateway,
    0_1474633305073_Skärmklipp_uno.PNG
    I have connected a 16Mhz crystal to the standalone circuit but that does not make any difference.
    I hav powered the breadboard mcu with 3.3V from my UNO and batteries (2xAA) but that doesn't make any difference either.

    I have no ideas what I should test next, any ideas?
    Environment: Win 10, Arduino IDE 1.6.11, Mysensors 2.0



  • So, after pulling my (now grey) hair, end after trying different sketches, both stable and beta version (2.0.1) of mysensors, different boot loaders, different fuses and so on, I discovered that if I connect the radio via cables and not directly to the board everything works as expected. Tried different radios and different boards with the same result.
    There are 2 caps near the radio, 10uF and 100nF.

    I´m not that skilled in electronics, so how come? Anybody knows? Is the radio to close to the mcu?

    Attached is a picture showing my boards.
    0_1474884471664_IMG_4773.JPG.jpeg


 

418
Online

7.9k
Users

8.7k
Topics

93.7k
Posts