#define MY_DISABLED_SERIAL not stopping all serial data



  • It looks like, that the #define MY_DISABLED_SERIAL not is stoping all serial data, from showing up on the serial port, on my GatewaySerial.ino.

    I have used:
    //#define MY_DEBUG
    #define MY_DISABLED_SERIAL
    .
    .
    void setup() {
    Serial.begin(115200);
    }

    But I have a temperatur sensor, that is sending data, to my GW, and it still show data on my GW serial port.

    Ex. temperatur from NODE 6:
    6;0;1;0;0,24.5
    6;0;1;0;0,24.6
    6;0;1;0;0,24.5
    6;0;1;0;0,24.4
    6;0;1;0;0,24.5

    How do I stop this, so that I can use my serial port, on the GatewaySerial, to other things.
    Btw. I only want to "grab" data, via the "void receive()" function.

    My setup:
    Last Mysensor 2.0.1-beta
    2 Arduino Mini Pro (8Mhz) 3.3V version
    2 NRF24l01+ with 47uF caps
    Use a 3.6V LiPo battery on both setup's.
    IDE 1.6.12


  • Admin

    The whole purpose of the serial gateways is to output incoming messages on the serial line.

    Why not create a none-gateway node?



  • @hek
    I was thinking of the same. Can you put me in a direction of an sketch, that I can use for that ?


  • Mod

    Why not create a none-gateway node?

    Or at least a non-serial gateway. Like ethernet gateway or mqtt gateway.



  • @mfalkvidd
    Dose it has to be a Gateway to "grab" the incomming data, from my sensor, or just a RepeaterNode ? Like a Sensor->Repeater only setup ? Have tryed this, but can't get it to work.


  • Mod

    @delinend a gateway sees all messages in a MySensors network. A repeater sees all messages passing through it. A node sees all messages sent to that node.



  • @mfalkvidd
    So before 2 NODE's only setup, can talk together, I have to remove the REGISTRATION_FEATURE ?



  • @hek
    Can 2 NODE's talk together, without a Repeater or a Gateway ? I have tryed many things, but I can't get any data in the void receive() 😞 I use the #defined MY_TRANSPORT_DONT_CARE_MODE, and the MY_PARENT_NODE_ID and MY_PARENT_NODE_IS_STATIC command setup (NODE ID 6 and 7).


 

378
Online

7.8k
Users

8.7k
Topics

92.9k
Posts