Raspberry Pi Gateway and Vera



  • I have successfully installed and run an Arduino with Ethernet shield for awhile now. I wanted to switch over to a Raspberry Pi Ethernet Gateway and run it with Vera. I have it running and Vera can communicate with the Pi.

    Here is what problem I am having.

    The Green Start button never shows up for the Pi. I can click it and see in the -d (debug mode) on the Pi that Client sends the following:

    mysgw: Client 0: 0;0;3;0;5;1
    mysgw: Client 0: 
    

    But nothing happens and I never see 0 devices found or anything when I click start.

    I'm not a super newbie when it comes to Arduino, OpenHAB and Vera but I am a newbie to using Raspberry Pi as a Gateway. Does anyone have any advice as to where to start troubleshooting this?

    Any help would be great and yes before you ask I searched the forums. :)



  • I am having the same issue. When I press start for inclusion on my VeraLite, it doesn't show the counter for any devices.



  • I know this topic is old, but I was experiencing the same problem and figured I would respond to it with the fix to the issue. Just in case someone else comes to the forum with the same issue.

    To get the start/include button to work after you upload the files to vera (from the Mysensors Github Repo)

    using putty or terminal SSH into your pi and type

    sudo nano /home/pi/MySensors/examples_linux/mysgw.cpp
    

    when nano opens hit ctrl-w to search for "MY_INCLUSION" and then remove the // marks before #define to enable inclusion mode on your pi gateway.

    #define MY_INCLUSION_MODE_FEATURE
    

    after that reboot and it should start to work. If you need to see what your gateway is doing I suggest enabling debug (Explained from the Pi Gateway installation from this site ... copied and pasted below for quick reference)

    When installed as a service, the output of the gateway will be directed to syslog in /var/log/syslog.
    If you want full debug output from the gateway to be logged to syslog (including serial protocol) you have to edit the following file: /etc/systemd/system/mysgw.service
    Add the -d parameter to the ExecStart line

    [Service]
    ExecStart=/usr/local/bin/mysgw -d
    

    hit control+x to exit and it will ask you if you want to save hit y and then enter.

    Then reload the systemd process and restart the gateway

    sudo systemctl daemon-reload
    sudo systemctl restart mysgw.service
    

    Now the output from the gateway can be monitored by

    tail -f /var/log/syslog
    

    Everything your Pi gateway is doing will be logged in real time in your putty or terminal window from the syslog file. Remove the -d from the /etc/systemd/system/mysgw.service file to remove all the debug info.

    When you enable debug you should be able to see that the gateway is listening for the children nodes. you may have to plug your children into your computer via usb and open arduino IDE and hit command+shift+M to open the serial monitor to see if your child node is working and broadcasting a signal properly.


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.