Beginner user: serial protocol help



  • hi everybody
    I'm a beginner user and I'm starting with serial protocol. There is something i'm doing wrong. I don't succes to comunicate with my V_LIGHT node. I have only one serial gateway and one V_light sensor with a led attached to PÌN1.
    I have uploaded the example sketch RelayActuator,and I've changed AUTO in gw.begin() for 150.
    I'm trying to switch off a led by passing 150;1;1;0;2;0 via COM5 monitor Serial. I can`t switch off the led and I have no reponse. The message dosen't reach the 150 node
    Any idea? is there any serial manual more detailed? is there any manual to use with Freedomotic?

    Thanks a lot


  • Hero Member

    I'm trying to switch off a led by passing 150;1;1;0;2;0

    The first child uses child-sensor-id = 0, not 1 AFAIK, so try 150;0;1;0;2;0.
    If that not works, first try a sensor and see if the gateway receives the sensor data.



  • hi daulagari

    I did as you say and i uploaded a BinarySwitchSensor and this is what i had as reponse from the serial monitor gateway:

    0;0;3;0;9;read: 255-255-0 s=255,c=3,t=3,pt=0,l=0:
    255;255;3;0;3;

    each time y reset the BinarySwitchSensor i have that as reponse

    thanks



  • I know that i'm receiving something, because each time i switch the sensor i receive the same message on the serial monitor screen buy it's always the same message. Nothing changes even if the pin3 is on ground or not:

    0;0;3;0;9;read: 255-255-0 s=255,c=3,t=3,pt=0,l=0:
    255;255;3;0;3;

    Thanks



  • OK, so the problem is that I`m not using any controler at all, but....

    Is it possible to do without a controler if i only want to set up a mini network with one gateway and one sensor? I assume to use static radio id.

    Anyway, is there any freedomotic setup mysensors manual? I cant setup the plug-in in windows by setting the serial port as this:

    <property name="serial.port" value="COM5"/>

    thanks to everybody for helping



  • Thanks to everybody, at least it worked!!!

    I gave a static ip adress for exaple 7 (not auto mode), and to comunicate (I have no controler installed yet) i changed the serial monitor to "new line" and y typed this to change the state of a led:

    7;1;1;0;2;0\n

    daulagari the child-sensor-id is 1, i think this is becasuse of the sketch RelayActuator

    Im very happy, Ive spend lot of houres. anyone konows a freedomotic setup mysensors manual? I`m a bit lost.


  • Hero Member

    @asterisco : See also the "cannot send id thread", 255;255;3;0;3; means the gateway is requesting an address from the controller for a node.

    From you last post I understand you assigned the node a static node-id of 7 and you are receiving that.

    I can not help with Freedomotic but why don't you try the Freedomotic thread?



  • Thanks
    ** I'm reading that thread** because I feel that the explanation about the Mysensors API and the serial protocol is just a little brief. I'd like to have a more detailed manual about serial protocol and the api,,, not only explaining the three main classes; MySensor, MyMessage and MyGateway but the constructor, and all the methods, propieties ...


  • Hero Member

    The gateway protocol is I think reasonably clear documented on http://www.mysensors.org/build/serial_api.



  • Hi, I feel the same way, being new to programming it inot clear to me how to change serial GW ore sensor sketch to get them to communicate. I have read the "Serial protocol" severel times but i still dont understand exactly what are the requried changes to set a simple GW to tempsensor network. My gateway can see transmits from sensor but no ID is set , i thought that was to handled automatically but
    appearantly thats not the case. Could i ask for some more basic explanation on the setup.
    regards Sigolhi


  • Admin

    First you must tell us what you want to achieve here.

    Normally you would have a controller in the setup to act on or store your sensor data (or as a GUI for sending out commands to your actuators). The gateway is just a gateway between the sensor network and the controller. All logic is normally handled over at the controller side including keeping track of and handing out ids to new sensors when they ask for it.

    To test things you can hook up the gateway to your Arduino IDE and serial monitor and answer the request for id yourself by typing in the reply. Or you can set a static id on the node which means it won't ask for it at startup.

    I suggest you have pick one of the open source controller softwares listed on www.mysensors.org to use the full potential of your home build sensors.



  • ok sigolhi, do as hek says. dont let your sensor into AUTO mode, and put an ID manually, for example 7.
    If you want to have all your sensor automatically addresed you must program a controller or use one of mysensors administrators suggest. I`m trying freedomotics, (because of windows) but i dont make it works yet. Things are not so easy. Mybe im gonna use my ARM card to try an other one.

    best



  • @asterisco
    Hi, i've tried the Fredomatic but the plugin from MySensor fails to install/configure. Any idea?
    Is there another controller that runs under windows that you can recommend for a try.
    Regards



  • This post is deleted!


  • my idead is to ask in the freedomotic thread:

    http://forum.mysensors.org/topic/339/freedomotic



  • Hi all,
    I've switched to EasyIoT's controller running on a raspberrypi (radio connected directly to the pi) and it works fine, only supports a few sensors sofar, but for my temperature tests it works fine.
    I haven't figured the log function yet but it looks promising.
    Great work by the people on http://iot-playground.com/about
    regards sigolhi



  • @sigolhi
    ok, i'll try your EasyIoT's, seems good.
    Where can i find documentation to connect the pi to the radio??? I've got olinuxino-lime, it's cheaper but there is not documentation about. I need to connect the board to the radio via SPI, and it's not easy.

    regards



  • @asterisco Hi,
    This is instruktion is on their website: http://iot-playground.com/2-uncategorised/3-easyiot-server-installation.
    hope it helps you.



  • @sigolhi

    This helps me a lot, but I'm not using RPi but olinuxino-lime a10 (european ARM board)

    regards


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.