[solved] Moteino Mega -> cannot compile 2.2.0 beta

  • Hi,

    I cannot compile any sketches:

    C:\Users\Alex\Documents\Arduino\libraries\MySensors/drivers/RFM69/old/RFM69_old.h:139:67: error: 'digitalPinToInterrupt' was not declared in this scope
            uint8_t interruptNum=digitalPinToInterrupt(MY_RFM69_IRQ_PIN))
    C:\Users\Alex\Documents\Arduino\libraries\MySensors/drivers/RFM69/old/RFM69_old.h:44:76: error: 'digitalPinToInterrupt' was not declared in this scope
     #define DEFAULT_RFM69_IRQ_NUM   digitalPinToInterrupt(DEFAULT_RFM69_IRQ_PIN)  //!< DEFAULT_RFM69_IRQ_NUM
    C:\Users\Alex\Documents\Arduino\libraries\MySensors/MyConfig.h:894:29: note: in expansion of macro 'DEFAULT_RFM69_IRQ_NUM'
     #define MY_RFM69_IRQ_NUM    DEFAULT_RFM69_IRQ_NUM
    C:\Users\Alex\Documents\Arduino\libraries\MySensors/hal/transport/MyTransportRFM69.cpp:151:61: note: in expansion of macro 'MY_RFM69_IRQ_NUM'
    Using library MySensors at version 2.2.0-beta in folder: C:\Users\Alex\Documents\Arduino\libraries\MySensors 
    Using library SPI at version 1.0 in folder: C:\Users\Alex\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.18\libraries\SPI 
    exit status 1
    Error compiling for board MoteinoMEGA.

    @scalz Do you know what the prolem is please?

  • Mod

    @alexsh1 seems like digitalPinToInterrupt isn't defined by the Moteino Mega board. How did you install support for that board? Maybe there is an update available?

    An alternative could be to manually map the pin to interrupt number using the pinout picture at https://lowpowerlab.com/shop/product/119

  • @mfalkvidd Yes, I have it installed and it does compile under 2.1.1 stable. No, there is no update for the board. It seems that it has to be defined manually for now

  • Admin

  • Hardware Contributor

    it compiles ok for me. I've just tried with latest dev branch..but for the moment i have 1.6.11 avr boards

    edit: forget what i said!! i compiled for mega2560 whereas it's moteino, 1284p,.. lol
    tekka is right :+1:

  • @scalz My avr is 1.6.18 (newest)
    I'll pull the latest dev and try again.

    EDIT: Thanks @tekka - I have corrected pins_arduino.h for Moteino Mega (attached)


Log in to reply

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.