Problem requesting data from Domoticz



  • Back in April I built an LCD node to display data from other sensors, using @AWI “LCD Clock and Text sensor node with new VText” (https://forum.mysensors.org/topic/1957/lcd-clock-and-text-sensor-node-with-new-v_text) as a model. It worked perfectly, requesting data every 4 minutes from the controller using request(Data1_ID, V_TEXT, 1); . I then had to put the project aside for a few months due to other priorities. Now am looking to finish the node and find that it no longer works - it never receives data from Domoticz.

    I am confident the sketch works fine. To test, I used MysController to send a message with a temperature and the sketch/node received it and displayed the data correctly. Therefore I logically assume something changed in Domoticz. I believe there was an update to Domoticz around July. I am trying to determine what has happened, especially since I have not seen any other messages in the forum that complain about the “request” no longer working.

    My node presents itself, and two S_INFO children, Domoticz properly creates the node and children in the hardware tab under the gateway. The two devices then appear in the Settings -> Devices tab with IDX’s. I use the same LUA script I used months ago to update the new IDX’s, and they update correctly. BUT ….. I notice that under Settings -> Devices the text data updates, but under Hardware tab the Child does not show any data in “values” column.

    Shouldn’t the Hardware tab show values for each V-TEXT child? (Especially since the device updates correctly under settings tab.)

    Has anyone else seen this?

    Thank you for any ideas!


  • Hero Member

    @novicit I was running the beta Domoticz and found the same thing. I rolled back to the stable version and requests worked once again.

    I have not updated domoticz for some time, running 3.5877 at present and this is working with requests.



  • @Boots33 , thank you for your input. Confirms for me that it is a Domoticz problem. Based on my quick research, Domoticz does not make it very easy to revert to a previous version once updated. Looks like I will have to attempt compiling an archive version, something I have never done before - and a challenge for my skill level. Thanks again!



  • I wanted to make sure this thread is correct. After a day of debugging I found the problem I was having.

    My sketch used the following:
    request(Data1_ID, V_TEXT, 1); The last variable (1) I believe is used to request an ack from the controller. Using MysController I was able to determine the 1 prevented MySensors from sending the request message somehow. When I changed it to 0, the requests were sent. Not sure if this is a bug, or intended.

    Also, I am using the current STABLE version of Domoticz, V3.8153, and it works fine in responding to the requests once I made the change above.

    Lastly, at least in the tab I was looking at in MysController, it never showed the response message going back from the controller to the node. Perhaps I did not look in the right place, or that is the way MysController is intended to operate. In either case the response messages were seen by the node.


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.