BMP180 suddenly disconnects from my I2C bus after a few minutes

  • Hello guys, I have a problem regarding my BMP180 sensor.
    When I restart my Pi everything is fine: I can see my BMP180 on my I2C bus (using i2cdetect) and the scripts I made work as intended.

    After a few minutes though, my BMP180 suddenly disappears from my I2C bus and the scripts return an I/O error.

    Can anyone help me? Thanks in advance!

  • Firstly check and re-mate all the contacts. Reflow the solder if it looks suspect under a magnifying glass.

    Second, measure voltage at the pi. What power supply are you using and what power cable to the pi?

    This would be the first things I would do in this situation.

  • Thank you for your quick response.

    I changed every wire and even tried it with another sensor - still the same problem.
    The voltage at the pi is 3.3V. I noticed that the problem occured after I changed the pull-up resistor of the 1-wire bus from 4k7 to 2k2 (before that everything worked as intended).

    Is there any intern pull-up resistor that I need to change or turn off/on?

Log in to reply

Suggested Topics