HASSIO Raspberry Pi + RF-NANO. Am I doing it right?

  • Hi guys. First time trying MySensors, it's not working, and I am not sure if I am following the correct approach:

    I have a working HASSIO (0.100.2) installation running on a Raspberry Pi 2+. I am trying to add a DHT-11 sensor (as the first shot with MySensors). The sensor is connected to a Keywish RF-NANO board (it's a nano clone with a NRF24 in the same board). When running a simple arduino sketch to read the DHT11 it works fine.

    On the Raspberry Pi I have connected a standalone NRF24L01 to the gpio following this: https://www.mysensors.org/build/raspberry

    Issues: First, Home Assistant should recognize the NRF24L01 and assign it to a /dev/ttyXXXX but it is not happening... I assume that this is because there is no sensor connected yet, but I'm still not sure. Maybe the whole setup is wrong.

    On the RF-NANO I load the example sketch from here: https://www.mysensors.org/build/humidity

    When started, I get this in the serial monitor:

    16:47:53.193 -> 16 MCO:BGN:INIT NODE,CP=RNNNA---,REL=255,VER=2.3.1
    16:47:53.193 -> 26 TSM:INIT
    16:47:53.193 -> 27 TSF:WUR:MS=0
    16:47:53.193 -> 33 !TSM:INIT:TSP FAIL
    16:47:53.193 -> 35 TSM:FAIL:CNT=1
    16:47:53.228 -> 37 TSM:FAIL:DIS
    16:47:53.228 -> 38 TSF:TDI:TSL

    I have NOT connected a capacitor yet (have to order it) in the NRF24L01 of the RasPi but I have placed both emitter and receptor close to each other with no difference.

    I am not sure if this is just a communication problem that will be solved with the capacitor, or the issue is with Home Assistant which is not detecting the NRF24L01, or with the NRF24L01, not being a NRF24L01+ (I have just noticed it)

    Am I doing it right? Is this the right way of connecting a mysensor to a HASSIO installation on a Raspberry Pi?

    Any help is really appreciated.

  • Mod

    Welcome to the forum @mioim !

    TSM:INIT:TSP FAIL means that the raspberry pi is unable to initialize the nrf24. The most common cause is a mistake in the wiring.

    Check the wiring again. If you don't find anything wrong, post a few photos and we'll try to help you.
    You can also try switching the nrf24, in case it is faulty.

    The tty should show up even without getting messages from the rf-nano.

  • Thank you, @mfalkvidd !

    I have double-checked the wiring and seems OK to me:

    Pin 17 (Raspberry pi 2+) (3.3v) - VCC (NRF24)
    Pin 19 - MOSI
    Pin 20 - GND
    Pin 21 - MISO
    Pin 22 - CE
    Pin 23 - SCK
    Pin 24 - CSN

    I have searched further and I am not sure if the installation and configuration of the mysensors gateway is still required on the raspberry pi as described here: https://www.mysensors.org/build/raspberry. The raspberry pi is running hassio and it's not possible to use 'git' or 'make' there.

    I cannot find clear information about installing mysensors on hassio apart from a few forum posts with issues.

  • Mod

    @mioim if hassio works like any other linux flavor, the instructions provided on MySensors should be sufficient.

    But from your description it seems like hassio is too special 😞

  • I think mysensors can't be installed on hassio except maybe if you know how to create addon for hassio. For me it was easier to create serial gateway on arduino NANO and connect it through USB to rPi3 with hassio.

  • Seconding @Nightbodom -- Can't currently use RPi GPIO connection for NRF radio when running HassIO. You must use a serial, ethernet, or mqtt MySensors gateway.

    And if you are going to need new hardware to set this up - you might want to look at ESP8266/32 as your gateway device as it has wifi/ethernet builtin.

  • Thank you, @Nightbodom and @Dave-Myers

    So, it looks like getting the RN-NANO boards and the NRF wasn't the best idea...

    What do you think about to use another raspberry pi (a Zero this time, running Raspbian for example) as a mqtt broker, connecting the NRF to it? The Zero hosting the mqtt broker and also the mysensors gateway? Or they must be on different devices?

  • I’m running Home Assistant with NRF24L01 with no problems at all.
    But I have manually installed it on Raspbian for that exact reason. You could do nothing by yourself when using HASSIO.
    It’s extremely easy to install it manually but not sure how easy it would be to migrate your existing environment.
    It may be worth it though. You get your freedom to do whatever you want with your Raspberry, back.

Log in to reply

Suggested Topics

  • 3
  • 3
  • 2
  • 15
  • 2
  • 24