NRF24 init problem

  • I have a problem with my NRF24(kind of always had some problems). I have the kind where you can see the IC, not any blob. So I hope they are genuine.
    I have a temperature sensor that worked for a couple of weeks, and then all of a sudden stopped to work. Now I have connected everything so I can see the debug output and get this:

    16 MCO:BGN:INIT NODE,CP=RNNNA---,FQ=16,REL=255,VER=2.3.2
    26 TSM:INIT
    28 TSF:WUR:MS=0
    36 TSM:FAIL:CNT=1
    39 TSF:TDI:TSL
    10041 TSM:FAIL:RE-INIT
    10043 TSM:INIT
    10049 !TSM:INIT:TSP FAIL
    10051 TSM:FAIL:CNT=2
    10053 TSM:FAIL:DIS
    10055 TSF:TDI:TSL
    20058 TSM:FAIL:RE-INIT
    20060 TSM:INIT
    20066 !TSM:INIT:TSP FAIL
    20068 TSM:FAIL:CNT=3
    20070 TSM:FAIL:DIS
    20072 TSF:TDI:TSL
    30075 TSM:FAIL:RE-INIT

    I've seen that before and therefore tried to change the NRF24 module to another one. But it didn't work. So just to test I rigged up a testbench with another Arduino and only connected the NRF24, and none of the modules that I have left is working as it should. And the spares I had have only been laying in a box. I don't understand what could be wrong? Can all of them die without ever being used?

  • Mod

    @raptorjr obvious errors could be cabling, power stability and power level.
    Hard to say and think along without a detailed description of your setup (which arduino, how is everything connected). I hope you didn't power the nrf24 with 5v...

  • @yveaux In my outdoor tempsensor everything was working for a while. And to avoid any problems with the initial setup I put a Nano on a breadboard with only the nrf24 connected.
    The first setup could have had some issues that I don’t know of, but strange that my test setup have the same problems? That should have avoided any hidden problems to test everything again in a new setup.

    And Arduino runs on 5V and nrf24 on 3.3V.

    Is there any other way to check the function of a nrf24? Maybe some other sketch that is not mysensor but able to verify the nrf24 works. I need to try to narrow down the problem because it seems strange that all 4 are broken.

Log in to reply

Suggested Topics

  • 87
  • 3
  • 10
  • 8
  • 9
  • 2