Weird voltage output - MQ2 sensor



  • I've got weird voltage output.
    First i built MQ2 sensor reading on the breadboard using ESP32, and it's working fine, voltage between A0 and GND are stable and (with using voltage divider with two 10k resistors) quite low - but after adding some smoke from Vape their voltage grows and analog output on ESP also shows that is higher. But when i copied that onto breadboard where you can solder things, that readings from MQ2 are unstable. Voltage jumps (also with using voltage divider) between 0.8V to 1.2 or 1.7V randomly. And it's odd because i seriosly don't know why it is happening. I also tested all wires between breadboard and that solder one and they are the same. The main difference is that, that on the breadboard i use a small wires to connect things on the breadboard and on the solder one i use 26AWG.

    Someone could help? There is no need to upload code from arduino CC. I can upload the wirings but, like i said, there are the same.



  • @sn0w This sounds like a floating input, or missing ground wire to me. Is the ground of the sensor connected to the Arduino?



  • Some of the MQ senors require a 24hour+ burn in before they stabilise.

    Also, check all wires for continuity and check all soldered joints for 'dry' joints, cracks or blobs. A photo of the project might help. REflow any solder joints to ensure good contact.



  • @electrik
    Hi,

    Yes, it's like floating input, but like i said before: on the breadboard its fine, but on the solder one it's floating. And yes, the ground connector are connected to the ESP32 GND pin.

    @skywatch

    I know that, the MQ2 sensors could require the 24h burning process, but on the breadboard it's fine just after plug-in.
    And sure, i could attatch the photo of the connection.

    https://imgur.com/a/HmrmScv



  • Hello again.

    I tested everything again and i couldn't see any problem with connections or missing ground to the GND pins.
    On the breadboard voltage it's stable after a while and oscilating around 360-380mV. But the same MQ2 sensor on the PCB oscilating around 400, 800, 1100 mV and it's not stable at all 😄

    I dont really get it. I've tried to use it with and without connecting to the USB (i thought that it's some GND missing and it could be stable after connecting USB cos the socket is a next GND, but no, still the same)

    Maybe the ESP32 wroom 32 needs additional connection to GND apart from the GND and VIN on the board? But the documentation says that: VIN to 5V and GND nothing more. I double checked the 5V regulator and it's regulated the 12V to stable 5V. I'm using thick wire to provide 5V and GND, maybe it's an issue? Should i use thinner one? But the other hand all voltage at the MQ2 or temperature sensor shows correct 5V. Even the ESP from the VIN shows correct voltage. Only output from MQ2 shows floating voltage and i dont know why because on the breadboard it's perfectly fine. :V its frustrating.

    I'm bet i missing something but i dont know what.


Log in to reply
 

Suggested Topics

  • 2
  • 3
  • 9
  • 8
  • 3
  • 21
  • 2
  • 8

108
Online

10.8k
Users

10.9k
Topics

111.8k
Posts