Mysensors Plugin - Lua Startup Failed



  • Hey there.
    So as the subject line says.
    I can't seem to get the mysensors plugin to work.
    I have followed the installation instructions but the 'device'
    show the following: "Lua Startup Failure"

    On the top of my screen there seems to be a log which says:
    "MySensors plugin : Choose the Serial Port
    MySensors Plugin[15] : Running Lua Startup"

    Anyone have any ideas of what to do to make it work?

    I'm on a Vera 3 with UI5 by the way.

    Thanks
    //Sven



  • I think you have the same as I did
    From where you are you. Need to go under apps-dev apps-config port
    There, change the baud rate to 115200 and select the ' my sensors plugin ' under the 'used by' pull down list .
    Important now to save this in Vera and then Hit Save , and then hit reload. That should be it.


  • Admin



  • Oh, maybe I should've scrolled XD

    Thanks a lot guys. This will probably fix it.
    //Sven



  • Hi, I have the same problem but when I go to serial port configaration all I get up is

    "Serial Port configuration
    If you connected the USB/serial device and it's not displayed here, reload Luup.Reload Luup
    Not available"

    Any help appreciated. Using vera lite u17. Thanks


  • Admin



  • Tried this, hasn't helped. Same message as before. This from device page.mysensor.PNG
    Would chinese clones be causing this problem?
    Thanks Jamie



  • @heeythere47 Did you try what @5546dug suggested above? Your Vera is wanting you to "choose serial port". Check the baud rate and make sure the 'MySensors plugin' is selected.



  • Hi,
    I have gone to apps-dev apps-config port. but it is not opening the menu up to allow me to set anything.

    I go into develop apps, create device & paste D_Arduino1.xml in Upnp Device Filename field.

    Thats fine device is created. At this point it is an "Unnamed device"

    Then I go back to develop apps Serial port configuration & get this
    serial port config.PNG
    ClickReload Luup & the device becomes
    mysensorplugindevice.PNG
    but i am still not able to choose serial port & if click start on the device I get
    lua startup failure message

    Cheers Jamie



  • Also have gone to z-wave settings & restarted luup engine. Thanks



  • I have come to the conclusion that my vera does not recognise theses nanos & have ordered what I hope is a genuine one by the price. I will see how that goes.
    Cheers Jamie



  • There is a cheaper version of the nano that uses the ch340 Usb to Serial, there is no driver on the open wrt, to recognize it,

    Please take a look at the bottom of your nano,
    Nano_2014_bot_ch340g.jpg

    if it´s the same of to photo, you will need to buy one with the FTDI chip:
    ArduinoNanoBack_3_sm.jpg



  • Hi,
    that is the chip on the nanos I bought. The serial gateway is working now I received a genuine nano & the cheap ones work fine with relays, motion sensors etc. All good.
    Thanks Jamie


 

Suggested Topics

230
Online

8.6k
Users

9.4k
Topics

99.0k
Posts