Codebender



  • Am trying to upgrade to V1.5, V1.4 works fine. With respect to this website. The codebender example for LED flash works just fine, yet codebender for V1.5 serial gateway(s) does not, keep getting the "error compiling" So I logged into my codebendor account, tried to upload mysensors zip file into my directory too big they have a limit of 2 MB so it won't take it. Next ed I searched codebender for mysensors files, found them, same issue "error compiling." Downloaded Mysensors library to IDE (version 1.0.6) on my PC, followed all library procedures , deleted old Arduino-master, now lots of compiler errors. Installed codebender app in both Chrome and Firefox, same issues. Went a little further today, the website codebender still will not load any gateways but it will load the following programs: Dimmer, Distance, Light, Moisture, Motion, Parking, Pulsepowermeter, Pulsewattmeater, RFID, Secret Lock. These work on either Chrome or FireFox. I am using an Arduino Nano 328, 5 VDC. Just to make sure I was not having a Nano problem, I tried a Pro Mini. This small group of programs listed above load on my Pro Mini 328, 5VDC just fine also. So there is something common with the other programs that has changed such they are not comparable with codebender, at least for my PC. And of course the programs I want to use are the ones that do not work. Please help!


  • Admin

    Just remove MySensors from your local libraries in your codebender account. The go to the website and clone a new example (with libraries).

    As of locally running IDE you should install the 1.6.x version.



  • @hek Well that works better. I still get "There was an error compiling" from codebender on the Mysensors webpage, but now not as many sketches as before. It took going back to your video on loading the IDE and the gateway sketch. It is different than the way I learned Arduino, so that may have been part of the problem. I also found multiple copies of several of the files all associated with previous API versions some with the same file name which I am sure Arduino got confused. So with all the house keeping and reloading the IDE, the bottomline I can now get V1.5 gateway to compile.


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.