[Solved] Slow response, binary senor and Vera



  • I have wired my AC doorbell through a optocoupler connected to a sensor built on Arduino Pro Mini. I have built the sensor as shown in the BinarySwitchSensor example. My setup is Vera UI7 with a serial gateway.

    The senors shows up on Vera UI. But the status change on the sensor is shown with a delay of several seconds. Any idea whats causing the delay? I dont have this delays on my Z-wave devices.


  • Admin

    Must be Vera. The gateway doesn't have the capacity to buffer/delay anything.



  • Probably the Vera, could try power cycling it to see if it speeds things up a bit?

    Could also ssh in to your vera and run:

    tail -f /var/log/cmh/LuaUPnP.log |grep Arduino
    

    Then push the bell and see how long it takes for it to show up in the log. If it show up there quickly, but you don't see the change on the web or other i/f the slowdown is either the vera itself or the system/device doing the display.

    I have a doorbell sensor and a trigger which sends a growl notification using the push plugin. The sensor also flashes a bright LED directly.

    I just tried 5 doorbell pushes while holding the laptop and phone. One took 4 seconds to hit the log and another couple to hit the phone. All the rest took only around 1 second to hit the log and another 1-2 for the growl notification to hit the phone.

    I am using the ESP8266 gateway, and was using an ethernet gateway before that. I originally used the serial gateway, but that was before I had the doorbell sensor.

    Dunno if any of that helps though.



  • Thanks for your help.

    The slow response is due to Vera and PLEG not the sensor.

    The log indicated almost an immidiate response. The UI changed about 1 second later. I have defined some lights to turn on by using PLEG and it take about 10 seconds for PLEG to send the z-wave commands. May have to go for the Vera Scenes instead of PLEG to hopefully speed things up.



  • It had nothing to do with PLEG.

    Changing the device variable IgnoreTripTime from 10 to 1 seems to have solved my problem :)

    As far as I can tell this may have to do with some bouncing problem with my sensor design...


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.