W5100 Ethernet Gateway Build Fails



  • New to MySensors so I have not changed any configurations from the 1.6.8 EthernetGateway.ino. Did uncomment the Softspi enable in myconfig.h and uploaded to clone Nano with W5100 and NRF24l01 radio. When the gateway is connected to the LAN I get the following responses:
    $ ping 192.168.1.66
    PING 192.168.1.66 (192.168.1.66) 56(84) bytes of data.
    64 bytes from 192.168.1.66: icmp_req=1 ttl=64 time=0.718 ms
    64 bytes from 192.168.1.66: icmp_req=2 ttl=64 time=0.333 ms
    ^C
    --- 192.168.1.66 ping statistics ---
    2 packets transmitted, 2 received, 0% packet loss, time 1000ms
    rtt min/avg/max/mdev = 0.333/0.525/0.718/0.193 ms

    and

    :~$ nc -zv 192.168.1.66 5003
    nc: connect to 192.168.1.66 port 5003 (tcp) failed: Connection refused

    Domoticz states it is unable to connect to specified port.

    Any help appreciated.


  • Mod

    The serial debug output is probably the easiest way to troubleshoot.

    Do you have more than one ethernet node on your network? If so, do they have different ip and mac addresses?



  • mfalkvidd,

    There was an issue with the 192.168.1.66 port. My headless server had wifi unintentionally enabled and both eth0 and wlan0 were connected, wlan0 had the 192.168.1.66 IP. This explains the ping results and the port closure. It was my error in assuming the .66 was the gateway I just connected.

    Now the problem is different but the results are still the same... no connection, no IP, no gateway:

    Here is the current cut/paste status:

    From MyConfig.h:#define SOFTSPI

    From EthernetGateway.ino: #define IP_PORT 5003 IPAddress myIp (192, 168, 1, 65);

    Message window on Arduino IDE:

    WARNING: Category '' in library UIPEthernet is not valid. Setting to 'Uncategorized'

    Sketch uses 29,632 bytes (96%) of program storage space. Maximum is 30,720 bytes.
    Global variables use 1,042 bytes (50%) of dynamic memory, leaving 1,006 bytes for local variables. Maximum is 2,048 bytes.

    Per these instructions:
    https://www.mysensors.org/build/ethernet_gateway

    This wiring is verified:

    Arduino Ethernet module
    GND GND
    3.3V VCC
    13 SCK
    12 MISO/SO
    11 MOSI/SI
    10 SS/CS

    With cable in RJ45 on W5100 card:

    PWR Led Steady
    FDX LED Flashing

    When plugging W5100 directly into router(no switches, no intermediate cabling) the router status light on that port never changes state, no recognition of the W5100.

    Ping is same with/without gateway... no 192.168.1.65!

    Is this meant to be?


  • Mod

    I don't have an ethernet shield myself, but the port on your router should light up and you should be able to ping 192.168.1.65. What does the serial debug output say?



  • This is the contents of serial debug output:

    �q

    Still no IP, no port, no light on router...



  • mfalkvidd
    Please stand down, problem is resolved. When I return to a peaceful place, I will fill in the details.

    BTW... Thank you for your quick responses... your suggestion re: look behind the hardware kept the boards off the target range.



  • Issue resolution: When the W5100 card silkscreen says +5V, it means it! Disconnected W5100 +5 pin from 3.3 Arduino and connected +5V and GND directly to power supply.... a glorious city of lights!

    I reviewed the guides to see if this was something I had missed but 3.3V is clearly stated as the proper connection. If these boards have version numbers on the silkscreen, I can't find it.

    I would like to suggest that you change this topic description to something more fitting so when someone else is presented with this same opportunity a port closure issue doesn't confuse the problem. I looked for an "edit" menu but, again, I can't find it.

    As always, the solution is simple. Finding the actual problem is what is complex. It ain't what you don't know, it is what you're absolutely certain of that just ain't so what get's ya!

    Thanks for you help, mfalkvidd. In spite of this rough start, being able to get assistance like yours encourages me about this adventure.


  • Mod

    @martrw goad I could help. To edit the topic name, click the three dots at the bottom-right of your first post and select Edit. Then click the row above the text formatting tools and change the text.


 

457
Online

7.9k
Users

8.8k
Topics

94.3k
Posts