Ethernet Gateway - 0;0;3;0;9;check wires

  • So after 3 weeks trying to get my Veralite to recognize my Serial Gateway with no success, I decided to try the Ethernet Gateway.

    I bought an ENC28J60 Ethernet adapter, and connected everything as described in the instructions. The Sketch compiles fine and uploads to the arduino, but when I look at the debugger I see this message: 0;0;3;0;9;check wires

    I have checked the wires about a thousand times, and have tried different Arduinos and several different RF adapters. At this point I can say I'm sure the cables are plugged in correctly (when I said I checked the wires a thousand times I really meant it).

    Is there anything else that I might be doing wrong that would cause this error message?

    Any help is appreciated. I really want to get my sensors working with my Vera.


  • Admin


    While this won't help with the Ethernet, to establish the serial connection for the serial gateway with your veralite, the following works fairly reliably.

    1. Unplug the gateway USB connector
    2. Click Reload
    3. Plug in the gateway USB connector
    4. Click Reload
    5. Configure serial port as detailed in instructions.

  • Admin

    Hope you noticed that radio wiring is a bit different when using the ethernet gateway?

  • @blacey
    Thanks for the tip. I did try following the steps you recommended several times and still no luck! Im starting to think my Vera might have a bad USB.

  • @hek
    Yeah I did noticed that and wired the Radio and Ethernet card according to that table.

  • Contest Winner

    @rafael.brasilia I have received that message as well, and from what I could learn, it is related to the power supply. The ethernet module is somewhat of a hog, and powering it on the same 3.3V as the radio is not really the most stable solution. And from what I know, it does not work at all with a RF module with PA. I think I will use a separate step-down converter on my gateway to feed the radio from the 5V instead and use the on-board 3.3V supply for the ethernet module. Still waiting for all my parts though before I can fully test out my design.

  • @Anticimex

    HA! I just came here to post what I had found and saw your post. My problem was also the power supply! I connected my Ethernet board to a different 3.3v power supply and BAM! Worked on the first try. Apparently the Arduino doesnt have enough juice to power both the Radio and Ethernet cards.

    Now I see Gateway Startup Complete on my debugger, but when I connect the Ethernet cable to my router nothing happens. I have set up the following DHCP Reservation on my router: - DE:AD:BE:EF:FE:ED

    Is this the correct MAC Address I should be using? I have already set the IP on my sketch to match the one above.

    Am I doing anything wrong?


  • Hero Member

    I dont think it supports DHCP - so assign a static IP in the sketch.

  • @gregl

    I assigned the static IP in the sketch. But in my router I need to set up a DHCP reservation to always provide that specific IP to my gateway right?

  • This is what my uipethernet-conf.h looks like. I commented the UDP section out. Is that correct?


    /* for TCP */

    /* for UDP */
    //#define UIP_CONF_UDP 1
    //#define UIP_CONF_BROADCAST 1
    //#define UIP_CONF_UDP_CONNS 4

    /* number of attempts on write before returning number of bytes sent so far

    • set to -1 to block until connection is closed by timeout */
      #define UIP_ATTEMPTS_ON_WRITE -1

    /* timeout after which UIPClient::connect gives up. The timeout is specified in seconds.

    • if set to a number <= 0 connect will timeout when uIP does (which might be longer than you expect...) */
      #define UIP_CONNECT_TIMEOUT -1


  • Shouldn't need to do any reserving in your DHCP server if it's hardcoded into your sketch.

    Leave the UDP defines in, just change the value, the 3 line section should look like:

    #define UIP_CONF_UDP 0
    #define UIP_CONF_BROADCAST 1
    #define UIP_CONF_UDP_CONNS 4

    Note that UIP_CONF_UDP is now 0 not one.

  • @soward

    So I changed my code as you recommended, and re-uploaded the sketch. Everything looks fine, I can even see my gateway communicating with one of my sensors in the debugger, but my gateway wont communicate with my Vera.

    I set the IP Address in the settings for my device in Vera to be the same as in the sketch (, but when i hit Start it says:

    "Cannot Send Command. Communication Error."

    When I connect my gateway to my router nothing happens. No lights blinking or anything.
    Anything else Im missing?


  • If it doesn't get a link light on the device and on the switch/router you plug it into -- something must be wired wrong. Double check all the wires going to the ENC board, starting with the power and ground. If you get a link light, you can try to 'telnet 5003' from a Terminal/Shell/Command prompt (dunno if you are on Linux/MacOS/WinXX). If it's working, that should get you connected and you should see commands going to/from the gateway.

    IIRC there is a power LED on the ENC board as well that should be on.

  • @soward
    I doubled checked all the wires and they look good. If I move them and connect in any other way I get a "Check Wires" error in the debugger when trying to initialize the Gateway.

    The way I have it wired right now It initializes fine and I can see the gateway talking with my sensors.

    The only thing is, if I connect both the Radio and the Ethernet card to the 3.3V pin in the Arduino directly, I get the "Check Wires" error. It seems like the Arduino doesnt have enough power for both cards, so I have the VCC and Ground pins on my Ethernet card connected to a different 3.3V power source and I was wondering if that maybe could be the problem.

    How is your Gateway wired? Do you have both the Radio and the Ethernet cards connected directly?

    Thanks for the Help!

  • I have ENC28J60-I/SO connected by ethernetcable to my Asus RT-n66u in LAN 4. But It will not show up in my router... On my ENC28J60 there is a red light on D1 and the ethernet port has a green light and a yellow flashing light.

    Serial monitor says 0;0;3;0;14;Gateway startup complete. But nothing more. I have followed the ethernet gateway guide and set an static ip in the sketch.. DHCP is on in my router.

    The only thing I see in my router is : That the cable is connected to something and that its 10 Half duplex.

    I have also tried to connect it to other LAN ports but no difference

    What could be wrong?

  • @rafael.brasilia Did you ever get this sorted? as i am having the same issue

  • Same here. I'm probably going to just order a wiznet since that seems to be consistently working for most.

Log in to reply

Suggested Topics

  • 10
  • 15
  • 1
  • 1
  • 10
  • 5
  • 2
  • 3