[SOLVED] Can't get Nano to show up in Device Manager



  • Please bear with me, I'm brand spanking new at this. Following the tutorial to build a gateway. Got to the point where I plug it into the computer, nothing happens. Realize I got Nano boards with CH340 chipset, so tried installing drivers I found online for them. Still nothing when I plug it in (one solid and one blinking light on board, but computer doesn't recognize anything). Tried installing some drivers from codebender.cc that are supposed to take care of this issue, and it walks through a workflow. Driver install goes fine, but at step where it will test my board, I need to select the board (no problem) and select a port. But it says there are no valid ports found. In my Device Manager under Ports(COM & LPT), I have one device for some Android device I have on COM3, but nothing else. I seem to be stuck at the point where I can't get a COM port for my Nano. Any help whatsoever would be very much appreciated!


  • Contest Winner

    @spectral_ranger first of all welcome to mySensors

    Probably a stupid question. But did you try rebooting? I some times have to do that on my Mac book, because otherwise my laptop doesn't see the Arduino.



  • Assuming it's something stupid is probably right! But not in this case... I did reboot, no change.



  • So my problem was the cable. I grabbed a mini-usb cable from an old charger I had, not realizing that not all usb cables are meant for data transfer. Got some more cables specifically made for data transfer, and everything works fine now.


  • Contest Winner

    @spectral_ranger glad to hear that you we're able to solve it


Locked
 

359
Online

7.9k
Users

8.8k
Topics

94.3k
Posts