Strange behavior of a Serial MS 2.0 Gateway (maybe it's Domoticz)


  • Contest Winner

    Long story so I'll keep it short.

    1. Created a serial MS 2.0 gateway with soft spi, using a nrf24l01 pa lna radio.
    2. Tested on an existing Domoticz installation with 1.5 Sensor Nodes (worked instantly)
    3. Attached the gateway to another Pi with freshly installed Domoticz
    4. Created a new sensor with a nrf24l01 connected on a NRF24l01 adapter
      alt text
      did not work. I only saw fpar warnings in the debug
    5. Connected the radio without the adapter, with capacitor. Didn't work
    6. Uploaded a 1.5 sketch: Communication started but stalled before initialization finished
    7. Uploaded 2.0 sketch (removed) capacitor. Communication succeeded.
    8. Created more nodes all worked.

    It did look like the new Domoticz instance needed an old 1.5 Sketch to get the communication up and running. I can't explain this behavior.. But since we didn't change the circuit after the 1.5 upload. I'm pretty sure that it wasn't power related.

    Also. After everything was up and running. Tested the radio without capacitor and was able to transmit for more than 30 meters successfully... Couldn't test a longer range. I ran into a wall ;-)


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.