Unable to register new node



  • Environment

    Controller: MyController.org version 0.0.3.Alpha2
    Gateway: MQTT
    Mysensors version: 2.0.x
    Number Nodes: 2
    Radio Type: MY_RADIO_NRF24
    Node CPU: Arduino Nano ATmega328

    Issue

    When I tried to add another node (any sensor type or no sensor at all) I am getting error, looks like the new node is not able to contact the gateway via radio. I enabled full debug and I am seeing the following messages:

    TSM:INIT
    RF24:write register, reg=0, value=14
    RF24:write register, reg=3, value=3
    RF24:write register, reg=4, value=95
    RF24:write register, reg=5, value=76
    RF24:write register, reg=6, value=39
    RF24:read register, reg=6, value=39
    RF24:read register, reg=5, value=76
    RF24:write register, reg=16, value=115
    RF24:write register, reg=29, value=6
    RF24:write register, reg=2, value=2
    RF24:write register, reg=1, value=0
    RF24:write register, reg=28, value=3
    RF24:flushRX
    RF24:flushTX
    RF24:write register, reg=7, value=112
    TSM:RADIO:OK
    TSM:FPAR
    RF24:stop listening
    RF24:write register, reg=0, value=14
    RF24:open writing pipe, recipient=255
    RF24:write register, reg=10, value=255
    RF24:write register, reg=16, value=255
    RF24:send message to 255, len=7
    RF24:flushTX
    RF24:write register, reg=7, value=48
    RF24:start listening
    RF24:write register, reg=0, value=15
    TSP:MSG:SEND 255-255-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSM:FPAR
    RF24:stop listening
    RF24:write register, reg=0, value=14
    RF24:open writing pipe, recipient=255
    RF24:write register, reg=10, value=255
    RF24:write register, reg=16, value=255
    RF24:send message to 255, len=7
    RF24:flushTX
    RF24:write register, reg=7, value=48
    RF24:start listening
    RF24:write register, reg=0, value=15
    TSP:MSG:SEND 255-255-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSM:FPAR
    RF24:stop listening
    RF24:write register, reg=0, value=14
    RF24:open writing pipe, recipient=255
    RF24:write register, reg=10, value=255
    RF24:write register, reg=16, value=255
    RF24:send message to 255, len=7
    RF24:flushTX
    RF24:write register, reg=7, value=48
    RF24:start listening
    RF24:write register, reg=0, value=15
    TSP:MSG:SEND 255-255-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    TSM:FPAR
    RF24:stop listening
    RF24:write register, reg=0, value=14
    RF24:open writing pipe, recipient=255
    RF24:write register, reg=10, value=255
    RF24:write register, reg=16, value=255
    RF24:send message to 255, len=7
    RF24:flushTX
    RF24:write register, reg=7, value=48
    RF24:start listening
    RF24:write register, reg=0, value=15
    TSP:MSG:SEND 255-255-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,ft=0,st=bc:
    !TSM:FPAR:FAIL
    !TSM:FAILURE
    TSM:PDT
    RF24:write register, reg=0, value=12
    RF24:power down
    

    I replaced the CPU, the radio, I added 4.7uf capacitor, 2 other nodes communicated properly.

    I need some help to understand the messages.

    Thank you very much,

    Gerson


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.