Need help due wireing Lan - GW RMF69 & W5500



  • Hello,
    my name is Sascha and I try to setup an ethnet gateway. My first sensor with DHT22 and an serial GW is working well, but now i need a ethernet gw. But it won`t be working. Did some have a connetion plan and a sketch for those hardware.
    Adrunino Nano
    RFM69CW
    and W5500 Modul.

    I hope some have this and can share/send it to/with me.

    BR from germany
    Sascha


  • Hardware Contributor

    Hi,

    I don't know for W5500 (i've only w5100 and i don't use it for the moment but it works, i've tested it )
    Maybe this can help : https://forum.mysensors.org/topic/2901/my-ethernet-gateway-board-w5500



  • Thank you for your reply, but this is my problem. There are always howtos for 2,4Ghz devices. How do I connect the w5500 und an rfm69 modul?


  • Hero Member

    @Snobs according to @jpaulin in this post the W5500 should be used in the same way as the W5100.

    I actually copied his setup and managed to get it to work. All the info you need should be available in the linked thread.



  • Ok I`ll try following setup :
    RFM69W:

    SCK = 13
    MISO = 12
    MOSI = 11
    CS = 10
    IRQ = 2
    

    IRQ is which Pin in RFM69 ? Perhaps DI00 ?
    Normaly I use the DI00 and the NSS Pin... but which is which

    W5500:

    SCK = 13
    MISO = 12
    MOSI = 11
    CS = 7
    

    Is the last question what sketch I use to complie ? The default from mysensors site with the ehternet gw sketch ? only switch from NRF to RFM.


  • Hero Member

    @Snobs the same thread contains some example sketches but you allso need to modify the w5100.h acording to the instruktions in the thread. How you modify it depends on the pins you use.



  • Thank you fpr ypur Support @korttoma but i cant get it to work. I have tried the W5500 with Ethernet2 Lib und an example. This works, m RFM69 is also working as serial gateway. I`ve tried to change the Ethernet2.h looks like this :

    EthernetClass() { _dhcp = NULL; w5500_cspin = 7; }
      void init(uint8_t _cspin = 7) { w5500_cspin = _cspin; }
    5;3;0;9;MCO:BGN:INIT OK,TSP=1
    

    But still not working. I think I'm too stupid :( That makes me sad.

    BR
    Sascha



  • Actually I try this and it won`t be working :(

    /**
     * The MySensors Arduino library handles the wireless radio link and protocol
     * between your home built sensors/actuators and HA controller of choice.
     * The sensors forms a self healing radio network with optional repeaters. Each
     * repeater and gateway builds a routing tables in EEPROM which keeps track of the
     * network topology allowing messages to be routed to nodes.
     *
     * Created by Henrik Ekblad <henrik.ekblad@mysensors.org>
     * Copyright (C) 2013-2015 Sensnology AB
     * Full contributor list: https://github.com/mysensors/Arduino/graphs/contributors
     *
     * Documentation: http://www.mysensors.org
     * Support Forum: http://forum.mysensors.org
     *
     * This program is free software; you can redistribute it and/or
     * modify it under the terms of the GNU General Public License
     * version 2 as published by the Free Software Foundation.
     *
     *******************************
     *
     * REVISION HISTORY
     * Version 1.0 - Henrik EKblad
     * Contribution by a-lurker and Anticimex,
     * Contribution by Norbert Truchsess <norbert.truchsess@t-online.de>
     * Contribution by Tomas Hozza <thozza@gmail.com>
     *
     *
     * DESCRIPTION
     * The EthernetGateway sends data received from sensors to the ethernet link.
     * The gateway also accepts input on ethernet interface, which is then sent out to the radio network.
     *
     * The GW code is designed for Arduino 328p / 16MHz.  ATmega168 does not have enough memory to run this program.
     *
     * LED purposes:
     * - To use the feature, uncomment MY_DEFAULT_xxx_LED_PIN in the sketch below
     * - RX (green) - blink fast on radio message recieved. In inclusion mode will blink fast only on presentation recieved
     * - TX (yellow) - blink fast on radio message transmitted. In inclusion mode will blink slowly
     * - ERR (red) - fast blink on error during transmission error or recieve crc error
     *
     * See http://www.mysensors.org/build/ethernet_gateway for wiring instructions.
     *
     */
    
    // Enable debug prints to serial monitor
    #define MY_DEBUG
    
    // Enable and select radio type attached
    //#define MY_RADIO_NRF24
    #define MY_RADIO_RFM69
    #define MY_RF69_SPI_CS 3
    
    // Enable gateway ethernet module type
    #define MY_GATEWAY_W5100
    
    // W5100 Ethernet module SPI enable (optional if using a shield/module that manages SPI_EN signal)
    //#define MY_W5100_SPI_EN 4
    
    // Enable Soft SPI for NRF radio (note different radio wiring is required)
    // The W5100 ethernet module seems to have a hard time co-operate with
    // radio on the same spi bus.
    #if !defined(MY_W5100_SPI_EN) && !defined(ARDUINO_ARCH_SAMD)
    #define MY_SOFTSPI
    #define MY_SOFT_SPI_SCK_PIN 14
    #define MY_SOFT_SPI_MISO_PIN 16
    #define MY_SOFT_SPI_MOSI_PIN 15
    #endif
    
    // When W5100 is connected we have to move CE/CSN pins for NRF radio
    #ifndef MY_RF24_CE_PIN
    #define MY_RF24_CE_PIN 5
    #endif
    #ifndef MY_RF24_CS_PIN
    #define MY_RF24_CS_PIN 6
    #endif
    
    // Enable to UDP
    //#define MY_USE_UDP
    
    #define MY_IP_ADDRESS 192,168,100,254   // If this is disabled, DHCP is used to retrieve address
    // Renewal period if using DHCP
    //#define MY_IP_RENEWAL_INTERVAL 60000
    // The port to keep open on node server mode / or port to contact in client mode
    #define MY_PORT 5003
    
    // Controller ip address. Enables client mode (default is "server" mode).
    // Also enable this if MY_USE_UDP is used and you want sensor data sent somewhere.
    //#define MY_CONTROLLER_IP_ADDRESS 192, 168, 178, 254
    
    // The MAC address can be anything you want but should be unique on your network.
    // Newer boards have a MAC address printed on the underside of the PCB, which you can (optionally) use.
    // Note that most of the Ardunio examples use  "DEAD BEEF FEED" for the MAC address.
    #define MY_MAC_ADDRESS 0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED
    
    // Enable inclusion mode
    #define MY_INCLUSION_MODE_FEATURE
    // Enable Inclusion mode button on gateway
    //#define MY_INCLUSION_BUTTON_FEATURE
    // Set inclusion mode duration (in seconds)
    #define MY_INCLUSION_MODE_DURATION 60
    // Digital pin used for inclusion mode button
    //#define MY_INCLUSION_MODE_BUTTON_PIN  3
    
    // Set blinking period
    #define MY_DEFAULT_LED_BLINK_PERIOD 300
    
    // Flash leds on rx/tx/err
    // Uncomment to override default HW configurations
    //#define MY_DEFAULT_ERR_LED_PIN 7  // Error led pin
    //#define MY_DEFAULT_RX_LED_PIN  8  // Receive led pin
    //#define MY_DEFAULT_TX_LED_PIN  9  // Transmit led pin
    
    
    #if defined(MY_USE_UDP)
    #include <EthernetUdp.h>
    #endif
    #include <Ethernet.h>
    #include <MySensors.h>
    
    
    void setup()
    {
    }
    
    void loop()
    {
    }
    

    PINs are :

    NANO  W5100  RFM69
    ------------------
    GND   GND    GND
    3.3V         VCC
    5V    VCC
    13    SCK    SCK
    6            NSS
    12    MISO   MISO
    11    MOSI   MOSI
    10    SS/CS
    

    and the startup like this

    0;255;3;0;9;MCO:BGN:INIT GW,CP=RRNGA--,VER=2.1.0
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSF:WUR:MS=0
    0;255;3;0;9;TSM:INIT:TSP OK
    0;255;3;0;9;TSM:INIT:GW MODE
    0;255;3;0;9;TSM:READY:ID=0,PAR=0,DIS=0
    0;255;3;0;9;MCO:REG:NOT NEEDED
    IP: 192.168.100.254
    0;255;3;0;9;MCO:BGN:STP
    0;25
    

    Did somebody see my fault ?
    BR
    Sascha


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.