Raspberry PI 3 - Serial Gateway failing with Serial - write failed: Resource temporarily unavailable



  • Hi all,
    Has anyone seen this before on a Raspberry PI, when I restart it is fine again
    root@mmm_gateway:~# systemctl status mysgw
    ● mysgw.service - MySensors Gateway daemon
    Loaded: loaded (/etc/systemd/system/mysgw.service; enabled)
    Active: active (running) since Mon 2017-02-20 10:06:27 SAST; 20h ago
    Main PID: 577 (mysgw)
    CGroup: /system.slice/mysgw.service
    └─577 /usr/local/bin/mysgw

    Feb 20 10:50:01 mmm_gateway mysgw[577]: Serial - write failed: Resource temporarily unavailable
    Feb 20 10:50:01 mmm_gateway mysgw[577]: Serial - write failed: Resource temporarily unavailable
    Feb 20 10:50:01 mmm_gateway mysgw[577]: Serial - write failed: Resource temporarily unavailable
    Feb 20 10:50:05 mmm_gateway mysgw[577]: Serial - write failed: Resource temporarily unavailable
    Feb 20 10:50:06 mmm_gateway mysgw[577]: Serial - write failed: Resource temporarily unavailable
    Feb 20 10:50:06 mmm_gateway mysgw[577]: Serial - write failed: Resource temporarily unavailable
    Feb 20 10:50:06 mmm_gateway mysgw[577]: Serial - write failed: Resource temporarily unavailable
    Feb 20 10:50:07 mmm_gateway mysgw[577]: Serial - write failed: Resource temporarily unavailable
    Feb 20 10:50:07 mmm_gateway mysgw[577]: Serial - write failed: Resource temporarily unavailable
    Feb 20 10:50:09 mmm_gateway mysgw[577]: Serial - write failed: Resource temporarily unavailable
    root@mmm_gateway:~#
    root@mmm_gateway:~# systemctl restart mysgw
    root@mmm_gateway:~# systemctl status mysgw
    ● mysgw.service - MySensors Gateway daemon
    Loaded: loaded (/etc/systemd/system/mysgw.service; enabled)
    Active: active (running) since Tue 2017-02-21 07:03:21 SAST; 1s ago
    Main PID: 30189 (mysgw)
    CGroup: /system.slice/mysgw.service
    └─30189 /usr/local/bin/mysgw

    Feb 21 07:03:21 mmm_gateway systemd[1]: Started MySensors Gateway daemon.
    Feb 21 07:03:21 mmm_gateway mysgw[30189]: Starting gateway...
    Feb 21 07:03:21 mmm_gateway mysgw[30189]: Protocol version - 2.1.1
    root@mmm_gateway:~#

    I don't see any errors in /var/log/messages

    Thanks!



  • Doesn't the WiFi & Bluetooth on the RPi 3 use the serial port? Have you looked in to that?



  • mmmh I havent, but I don't use either on this implementation... Has not happened again.... Confusing...


  • Mod

    Consider using the ethernet gateway if you keep having trouble with the serial one


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.