Mysensor gateway UNO shield W5100



  • Hi! can someone help me please

    i have a problem.
    when i try to contact the gateway in domoticz i get the folowing message:

    2017-08-21 21:01:15.700 TCP: Reconnecting...
    2017-08-21 21:01:16.700 MySensors: connected to: 10.0.1.20:5003
    2017-08-21 21:01:25.701 MySensors: Connection reset!
    2017-08-21 21:01:25.701 TCP: Reconnecting in 30 seconds...

    i use the folowing sketch:

    /**

    • The MySensors Arduino library handles the wireless radio link and protocol
    • between your home built sensors/actuators and HA controller of choice.
    • The sensors forms a self healing radio network with optional repeaters. Each
    • repeater and gateway builds a routing tables in EEPROM which keeps track of the
    • network topology allowing messages to be routed to nodes.
    • Created by Henrik Ekblad henrik.ekblad@mysensors.org
    • Copyright (C) 2013-2015 Sensnology AB
    • Full contributor list: https://github.com/mysensors/Arduino/graphs/contributors
    • Documentation: http://www.mysensors.org
    • Support Forum: http://forum.mysensors.org
    • This program is free software; you can redistribute it and/or
    • modify it under the terms of the GNU General Public License
    • version 2 as published by the Free Software Foundation.

    • REVISION HISTORY
    • Version 1.0 - Henrik EKblad
    • Contribution by a-lurker and Anticimex,
    • Contribution by Norbert Truchsess norbert.truchsess@t-online.de
    • Contribution by Tomas Hozza thozza@gmail.com
    • DESCRIPTION
    • The EthernetGateway sends data received from sensors to the ethernet link.
    • The gateway also accepts input on ethernet interface, which is then sent out to the radio network.
    • The GW code is designed for Arduino 328p / 16MHz. ATmega168 does not have enough memory to run this program.
    • LED purposes:
      • To use the feature, uncomment MY_DEFAULT_xxx_LED_PIN in the sketch below
      • RX (green) - blink fast on radio message recieved. In inclusion mode will blink fast only on presentation recieved
      • TX (yellow) - blink fast on radio message transmitted. In inclusion mode will blink slowly
      • ERR (red) - fast blink on error during transmission error or recieve crc error
    • See http://www.mysensors.org/build/ethernet_gateway for wiring instructions.

    */

    // Enable debug prints to serial monitor
    #define MY_DEBUG

    // Enable and select radio type attached
    #define MY_RADIO_NRF24
    //#define MY_RADIO_RFM69

    // Enable gateway ethernet module type
    #define MY_GATEWAY_W5100

    // W5100 Ethernet module SPI enable (optional if using a shield/module that manages SPI_EN signal)
    //#define MY_W5100_SPI_EN 4

    // Enable Soft SPI for NRF radio (note different radio wiring is required)
    // The W5100 ethernet module seems to have a hard time co-operate with
    // radio on the same spi bus.
    #if !defined(MY_W5100_SPI_EN) && !defined(ARDUINO_ARCH_SAMD)
    #define MY_SOFTSPI
    #define MY_SOFT_SPI_SCK_PIN 14
    #define MY_SOFT_SPI_MISO_PIN 16
    #define MY_SOFT_SPI_MOSI_PIN 15
    #endif

    // When W5100 is connected we have to move CE/CSN pins for NRF radio
    #ifndef MY_RF24_CE_PIN
    #define MY_RF24_CE_PIN 5
    #endif
    #ifndef MY_RF24_CS_PIN
    #define MY_RF24_CS_PIN 6
    #endif

    // Enable to UDP
    //#define MY_USE_UDP

    #define MY_IP_ADDRESS 10,0,1,20 // If this is disabled, DHCP is used to retrieve address
    // Renewal period if using DHCP
    //#define MY_IP_RENEWAL_INTERVAL 60000
    // The port to keep open on node server mode / or port to contact in client mode
    #define MY_PORT 5003

    // Controller ip address. Enables client mode (default is "server" mode).
    // Also enable this if MY_USE_UDP is used and you want sensor data sent somewhere.
    //#define MY_CONTROLLER_IP_ADDRESS 192, 168, 178, 254

    // The MAC address can be anything you want but should be unique on your network.
    // Newer boards have a MAC address printed on the underside of the PCB, which you can (optionally) use.
    // Note that most of the Ardunio examples use "DEAD BEEF FEED" for the MAC address.
    #define MY_MAC_ADDRESS 0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED

    // Enable inclusion mode
    #define MY_INCLUSION_MODE_FEATURE
    // Enable Inclusion mode button on gateway
    //#define MY_INCLUSION_BUTTON_FEATURE
    // Set inclusion mode duration (in seconds)
    #define MY_INCLUSION_MODE_DURATION 60
    // Digital pin used for inclusion mode button
    //#define MY_INCLUSION_MODE_BUTTON_PIN 3

    // Set blinking period
    #define MY_DEFAULT_LED_BLINK_PERIOD 300

    // Flash leds on rx/tx/err
    // Uncomment to override default HW configurations
    //#define MY_DEFAULT_ERR_LED_PIN 7 // Error led pin
    //#define MY_DEFAULT_RX_LED_PIN 8 // Receive led pin
    //#define MY_DEFAULT_TX_LED_PIN 9 // Transmit led pin

    #if defined(MY_USE_UDP)
    #include <EthernetUdp.h>
    #endif
    #include <Ethernet.h>
    #include <MySensors.h>

    void setup()
    {
    }

    void loop()
    {
    }

    when i use the serial monitor in arduino app i get:

    0;255;3;0;9;MCO:BGN:INIT GW,CP=RNNGA--,VER=2.1.1
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSF:WUR:MS=0
    0;255;3;0;9;TSM:INIT:TSP OK
    0;255;3;0;9;TSM:INIT:GW MODE
    0;255;3;0;9;TSM:READY:ID=0,PAR=0,DIS=0
    0;255;3;0;9;MCO:REG:NOT NEEDED
    IP: 10.0.1.20
    0;255;3;0;9;MCO:BGN:STP
    0;255;3;0;9;MCO:BGN:INIT OK,TSP=1
    0;255;3;0;9;Eth: connect

    what do i do wrong?


  • Mod

    @bobbybobbybobby nothing wrong except that the latest Arduino boards are broken. See https://forum.mysensors.org/post/72423

    (Most likely problem at least)

    Arduino AVR Boards was at version 1.6.19. which did not work. I downgraded to 1.6.11



  • @mfalkvidd

    Great!! it works thanks for the fast reply


  • Mod

    there is 1.6.20 out... you could give it a shot, maybe they fixed something :D


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.