MYScontroller



  • I know I read it it in the LONG thread on @tekka development of this but whether through age or frustration I cannot find where somebody explained exactly where it should be after downloading.
    I am having a battle royal with Domoticz (my elected choice which I am now having serious reservations over) it recognises hardware then fails to list devices... Worked great with the one-wire node initially (my first succesfull deployment of a node) but seems to have had a brain-fart after adding the gas meter reading node.
    I would really like to identify if the problem lies with Domiticz or the Gateway behaviour, as otherwise it would seem to become a blame-game from which helps nobody.
    Anybody can guide me on this as I value what little hair I have left 😉


  • Mod

    I don't get the question about myscontroller. About Domoticz, if you deleted a node it will not show up unless you press the big button "allow new devices for 5 minutes" in settings or change the node ID to a number you never used



  • @gohan Yeah thanks for that. Discovered finally the 3 month old Sandisk Ultra 64Gb was goosed, presumably the fragmented beginning of the end for Domoticz, so probably now looking to dump everything to a hard drive...
    Yep, tried deleting a Node, it would delete, Domoticz would never recognise it's existence again, even if I changed the Node Number, rebooted, ran in circles for 10 minuted, or just went to sleep... Nothing made any difference, although I didn't try percussive maintenance despite having an excellent selection of weapons at my disposal.. It was banished it seemed...
    Thought this may be SD related, so full reinstall required anyway... Ho hum...
    Reinstalled the Pi3 per the book as had a spare microSD, then hit a brick wall (despite a fresh install of Raspbian on the new SD, a new install of Domoticz resulted in zero comms on 8080 port...
    After some digging around I finally found a workaround to a flaw which existed prior to August it appears, and now I am staring at a screen with a recognised gateway (finally), with one node out of the two recognised, a temperature node with 10 DSB20s working (yes, I uploaded the checking sketch to crosscheck the chip idents and functionality (I had only added one more DSB)), yet Domoticz shows a Door Sensor under Node 0, and 8 out of the 10 temp sensors plus the usual Child ID 255 S_ARDUINO_NODE under Node 5, no sign of the Gas Node which was fully functional previously also, either there is something wonky with this Pi3 or...

    I am rapidly losing faith in Domoticz as a Controller, it may be pretty as a graphing tool, but it seems to work flawlessly for some, and others develop an interesting vocabulary...

    I finally found the post I was originally looking for, but it didn't help, by then I had figured out the FUKD SD card...

    Thank God beer is cheap here....


  • Mod

    I found DietPi distribution very handy for my controller: it has many automated scripts, backup/restore functions, TempFS mounted to /tmp if you want to use it for logs without wearing the SD card, any many other small things. Give it a try. I only had a problem of SD card corruption once, when I got power outage and I didn't have the battery backup in place and the SD was a cheap one



  • @gohan Thanks for that heads up, will look at it, but now I am convinced the SD card should remain Read Only for the Pi and a SSD/HDDhard drive is the storage and OS solution. Have used SDs for years (>10 intermittent) without a single fail. This is my first experience of it, but I cannot help but wonder how long the next one will last.
    Once I have a stable setup I will migrate all active stuff to an external drive.
    The Gas Sensor Node has still not shown up, the 8 out of 10 temp sensors are unchanged, I checked again on the Node and it picks up all 10, the Gateway is the standard, the problem MUST be Domoticz.
    I believe an alternative less opaque controller is the next step..


  • Mod

    There is also a mount read only option built in for root file system, but I still have to investigate it



  • @gohan I appreciate your interest, but as I said previously I am more comfortable with migrating the OS and storage to a traditional/?device which can withstand the abuse. I may just have been unlucky in this instance with the micro-SD, but having spent a day trying to get a working system, however frugal, up and running again, I would rather have reliability. I can backup data to the router drive, I can copy a spare micro-SD for the Pi3, that seems to me a safe system...


Log in to reply
 

373
Online

6.7k
Users

7.6k
Topics

80.4k
Posts

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.