Newline of debug output



  • Hey when one tries to read the serial output of a gateway/node directly, it doesn't seem to send a correct newline char at the end of a line.

    I tried reading the output of a gateway /dev/ttyUSB0 with:

    picocom -b 115200 /dev/ttyUSB0
    

    But the output looks like:

    0;255;3;0;9;MCO:BGN:INIT GW,CP=RNNGA--,VER=2.1.1
                                                    0;255;3;0;9;TSM:INIT
                                                                        0;255;3;0;9;TSF:WUR:MS=0
                0;255;3;0;9;TSM:INIT:TSP OK
                                           0;255;3;0;9;TSM:INIT:GW MODE
                                                                       0;255;3;0;9;TSM:READY:ID=0,PAR=0,DIS=0
                             0;255;3;0;9;MCO:REG:NOT NEEDED
                                                           0;255;3;0;14;Gateway startup complete.
                 0;255;0;0;18;2.1.1
                                   0;255;3;0;9;MCO:BGN:STP
                                                          0;255;3;0;9;MCO:BGN:INIT OK,TSP=1
    
    

    I have also tried Using minicom and screen. All show the same

    EDIT:
    I found out, that I can use cat if I first set the baudrate correctly:

    stty -F /dev/ttyUSB0 115200
    cat /dev/ttyUSB0
    

    This works, but I wonder what is going on in the case if picocom

    EDIT:
    Okay, I found the solution. I guess its the same for minicom as well.

    picocom -b 115200 /dev/ttyUSB1 --imap lfcrlf
    

    the --imap lfcrlf maps line feed to line feed and carriage return. This then gives the desired formatting.


  • Mod

    If you compile an ethernet gateway, you can use myscontroller to debug


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.