Newbie. Problems with Password on Domoticz. Help!

  • Can anyone help a newbie that has just built his first sensors, Gateway and Controller (Domoticz). I was pleased that I had managed to get everything working fine and started to see what else I could do with Domoticz when somehow I locked myself out. I certainly don't recall setting any passwords or even messing with those settings but now my Domoticz is requesting a username and password. I have tried the usual admin, admin and my windows password but it refuses to let me in. On the Domoticz website it suggests starting the program from shell with "./domoticz -nowwwpwd". Trying this starts the program but it still demands a password. I have deleted the program and reloaded but still it starts with a password request. Any ideas before I give up on Domoticz. My system is built around a Wondows 7 environment with Arduino Nanos and esp8266 for a gateway.

  • @Purclewan What kind of device are you running Domoticz on? Windows, Raspberry PI/Linux? The reason I ask is because there may be slight differences on the procedure for this. I am assuming that you looked at this link: The example on that page is for the Raspberry PI/linux. From the sounds of it, you didn't stop Domoticz service before running your "./domoticz -nowwwpwd" command. If Domoticz is still running in the background, "./domoticz -nowwwpwd" will not work.

    This is what the manual says:
    Resetting the Website Username/Password
    To reset the website username/password incase this is lost… there are two options.

    • Specify –nowwwpwd as command line argument
    • Place a file labeled ‘resetpwd’ inside the root Domoticz installation folder.
      Each minute the existence of this file is checked, and if found the Username/Password is reset and the file is

  • Many thanks for the prompt reply. Appreciate others offering help.
    I had gone through the processes you mentioned but without success and was on the point of giving up until I had what seemed like a daft thought, at least until I tried it.

    I reset everything as previously but this time before starting Domoticz from the cmd line I cleared my web browser cache. When I started Domoticz this time it opened without a password. I have repeated this a couple of times and it seems that clearing the browser cache is a required step, at least on Windows. I mention this in case others have the same problem.

    So, on with the build, two sensors working with a bridge. Time to scale up :~)

  • @Purclewan Great. Glad you found the fix.

    Welcome to the community. If you have any other issues, there is a great team of people in her that can help with pretty much any problem you run into, so don't be afraid to post. They say that the only dumb question is the one that is not asked.

Log in to reply





Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.