No debug data from sensors or gateway. Bad radios?

  • Hello all

    I bought some suspicious NRF24L01+ -radios from ebay and I wonder if they're the source of my troubles.

    This is what they look like:


    Now I know they don't look like the regular ones but when I tried the pingpong sketch they reported themselves as NRF24L01+ and worked!

    But. When I use them on any example sketch for a node the node doesn't print anything on the serial console. (Yes, I've enabled debugging in MyConfig.h (well, it's enabled by default)).

    A serial gateway on vera seems to work but doesn't include any nodes (the inclusion process starts and stops as expected). I don't know how to verify if the radio works. The only thing the gateway prints on serial when connected to a PC is 0;0;3;0;14;Gateway startup complete.. Nothing else.

    Weirdly, I tried MySensors version 1.3 and did manage to get something on serial from the nodes:

    Started sensor. Open ping reading pipe: 255 Tx: fr=255,to=255,la=255,ne=255,ci=255,mt=4,ty=9,cr=184: No relay nodes was found. Trying again in 10 seconds.

    ...and from the serial gateway:

    0;0;4;11;Arduino startup complete.

    nothing else.

    I'm using arduino IDE 1.0.6 and Mysensors 1.4.1 and I've read and tried every troubleshooting trick including checking the wiring ten times, adding decoupling capacitors and trying different arduinos (uno, nano, pro mini)

    Anyone with any clues?

  • Admin

    You probably got the HopeRF RFM73 which is a NRF-clone if I've understood it correctly.

  • @hek OK, so it would be possible to get these things to work by tweaking the code but I assume it's not worth the trouble.

    Just out of curiousity: why would they work with the pingpong sketch? Does it initialize the radio differently?

  • @slarti I think that the difference is that the ping pong test doesn't use acknowledge and my experience from NRF24L01 (no plus) chip it that it is the ack thing that differ and that cause the problem.

    My recomendation: by new radios from the link on MySensors Store page.

  • @olaeke Yeah, thanks, I've already done that a week ago but the waiting is really frustrating on a weekend when I have time for this stuff. I think I need to hunt down an european supplier for mission critical stuff like the radios.

  • @slarti Yea I know the feeling, I had planed for Home Automation stuff in the Christmas holiday then I got this shit from China a non working Vera so it was quite frustrating

  • Ha, have a bag of same ones - luckily only about 5 of em and reordered proper ones after failing all attempts to make these work.. I just wonder.. is there any use for these? they obviously transmit and receive data

  • Thanks for this great testing code.

    The default pong back role wasn't working for me (and therefore no data was received from the remote unit) so I changed the following section of your code from:

    // Openning for listening



    // Openning for listening

    Am not sure if the "radio.openWritingPipe(pipes[1])" (copied from the change role code further down in your source) line is required, but it works.

    Thanks again.


Log in to reply

Suggested Topics

  • 3
  • 1
  • 3
  • 3
  • 2
  • 1
  • 12
  • 2