Domoticz cannot see devices from my sensors



  • Hi All,

    I'm compleatly new to mysensors however I've read a lot about this. Now decided to create my own mysensors network with domoticz and attached ethernet GW (on raspberrypi) using NRF24 modules.
    I've got a succesful GW and configuration in domoticz and I've created my own first node with simple soil moisture sensor.
    Now I see the node in the domoticz gui and I see its detected correctly, passing data:
    0_1522956890902_domoticz1.PNG
    Now all looks to be good. Domoticz is receiving data presentation of the node is also ok but domoticz is not presenting device which I can add. Actually I don't see any device from Mysensor GW (or Mysensors GW in the device list).
    0_1522956905439_domoticz2.PNG

    Is there anything which I'm doing wrong? I think this is a simple mistake but I've spent almost 4h figuring out that my radio was badly connected so I'm out of ideas. Any suggestion would be welcome.


  • Mod

    @piotr-piwonski welcome to the forum!
    Have the nodes sent any data yet? Domoticz doesn't display devices until they have sent their first data. Presenting is not enough.



  • Thanks for the welcome 🙂
    Yep it did send data. If you look closer at the V_LEVEL you see 8. When I see changes on the node serial monitor and refresh domoticz it the V_LEVEL reflects the changes. So looks like the data are sent and parsed by GW and Domoticz.


  • Mod

    ok. Sorry I didn't notice.

    This is what my humidity sensors look like
    0_1522958266852_bf7ff28b-2b0f-4dff-90b8-91fdf9098c42-image.png

    I am using S_HUM and V_HUM instead. But according to https://www.mysensors.org/controller Domoticz should support S_MOISTURE.

    I don't want to derail this thread, but how come you have more than 7,000 devices in Domoticz?



  • I've got also 433 RFlink attached to the same domoticz. Most of the devices are fantoms on that RF433 link.
    This is also why I want to move to Mysensors and NRF24 modules.
    I'll try tomorrow change my nodes to use a S_HUM and V_HUM.



  • @bbrowaros Have you enabled: "Accept new devices" from settings?



  • @pjr that was it. I've disabled it due to 433 link and the noise which was generating and forgot about it. Thanks all for help.



  • @bbrowaros It has happened to me so many times that it was easy to guess 😄


 

339
Online

7.8k
Users

8.7k
Topics

93.0k
Posts