RPi gw broken, invalid message length



  • I had a perfectly working system, but to get logging I reinstalled everything. Now it's broken.
    RPi Zero W (dietpi), MQTT gw, mosquitto, Openhab2, NRF24.
    Installation goes fine. Configure command:

    ./configure --my-transport=nrf24 --my-rf24-irq-pin=15 --my-signing-debug --my-signing=password --my-security-password=XXXXXXXXXX --my-gateway=mqtt --my-controller-ip-address=127.0.0.1 --my-mqtt-user=YYYY --my-mqtt-password=ZZZZZ--my-mqtt-publish-topic-prefix=mysensors-out --my-mqtt-subscribe-topic-prefix=mysensors-in --my-mqtt-client-id=mygateway1 --my-leds-err-pin=12 --my-leds-rx-pin=16 --my-leds-tx-pin=18 --my-config-file=/etc/mysensors.conf
    

    Mysgw startup goes fine. Then the problems start:

    Aug 08 23:21:27 DEBUG TSF:MSG:READ,23-162-105,s=223,c=3,t=34,pt=2,l=17,sg=0:19080
    Aug 08 23:21:27 DEBUG !TSF:MSG:LEN,16!=24
    Aug 08 23:22:29 DEBUG TSF:MSG:READ,58-6-85,s=14,c=5,t=81,pt=0,l=13,sg=1:????x+
    Aug 08 23:22:29 DEBUG !TSF:MSG:LEN,16!=32
    Aug 08 23:22:31 DEBUG TSF:MSG:READ,116-5-135,s=184,c=1,t=215,pt=3,l=17,sg=0:29731
    Aug 08 23:22:31 DEBUG !TSF:MSG:LEN,16!=24
    Aug 08 23:22:33 DEBUG TSF:MSG:READ,136-132-215,s=249,c=5,t=1,pt=7,l=10,sg=0:-0.35548508
    Aug 08 23:22:33 DEBUG !TSF:MSG:LEN,16!=17
    Aug 08 23:22:35 DEBUG TSF:MSG:READ,194-137-143,s=33,c=7,t=101,pt=7,l=8,sg=0:104405227536384.00000000
    Aug 08 23:22:35 DEBUG !TSF:MSG:LEN,16!=15
    Aug 08 23:23:38 DEBUG TSF:MSG:READ,154-105-25,s=119,c=6,t=21,pt=2,l=23,sg=1:-15540
    Aug 08 23:23:38 DEBUG !TSF:MSG:LEN,16!=32
    Aug 08 23:23:40 DEBUG TSF:MSG:READ,146-49-193,s=128,c=1,t=186,pt=1,l=0,sg=0:103
    Aug 08 23:23:40 DEBUG !TSF:MSG:LEN,16!=7
    Aug 08 23:23:42 DEBUG TSF:MSG:READ,145-68-141,s=151,c=0,t=111,pt=1,l=14,sg=0:191
    Aug 08 23:23:42 DEBUG !TSF:MSG:LEN,16!=21
    

    I have no sensors with those id's of course.
    Also mysgw.service does not start up automatically anymore (systemctl enabled etc). If I start it manually, it shuts down after a while. I have tried branch master ja develpment. No difference.
    Again, everything worked fine before reinstall, so not a h/w problem.

    Help? Ideas?



  • Apparently sleeping less and debugging late solves problems. This is SOLVED.

    My IDE library was outdated. I updated my Arduino Mysensors-library, upload to one node, and my node started to communicate fine. Must reupload all nodes unfortunately. Probably the problems are caused by signing differences in previous library versions vs. 2.3.0 release for Raspberry.

    Again, hope this helps someone who encounters the same problem.


 

295
Online

7.6k
Users

8.5k
Topics

91.2k
Posts