WIFI Gateway using ESP8266 error during compile



  • I am trying to setup Building a WiFi Gateway using ESP8266 and followed the instructions carefully. When I tried to compile using Arduino IDE 1.9.0, I get the following error: exit status 1
    Error compiling for board NodeMCU 1.0 (ESP-12E Module ).
    Please help what is missing or what I am doing wrong?

    Arduino: 1.9.0-beta (Windows 8.1), Board: "NodeMCU 1.0 (ESP-12E Module), 80 MHz, Flash, 4M (1M SPIFFS), v2 Lower Memory, Disabled, None, Only Sketch, 115200"

    In file included from C:\Users\Javed\OneDrive\Documents\MySensors-master\libraries\MySensors/MySensors.h:420:0,

                 from C:\Users\Javed\OneDrive\Documents\MySensors-master\MySensors-master\examples\GatewayESP8266\GatewayESP8266.ino:118:
    

    C:\Users\Javed\OneDrive\Documents\MySensors-master\libraries\MySensors/hal/architecture/ESP8266/MyMainESP8266.cpp:57:53: error: declaration of C function 'void ets_update_cpu_frequency(int)' conflicts with

    extern "C" void ets_update_cpu_frequency(int freqmhz);

                                                     ^
    

    In file included from C:\Users\Javed\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.4.2\cores\esp8266/pgmspace.h:10:0,

                 from C:\Users\Javed\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.4.2\cores\esp8266/Arduino.h:256,
    
                 from sketch\GatewayESP8266.ino.cpp:1:
    

    C:\Users\Javed\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.4.2/tools/sdk/include/ets_sys.h:218:6: error: previous declaration 'void ets_update_cpu_frequency(uint32_t)' here

    void ets_update_cpu_frequency(uint32_t ticks_per_us);

      ^
    

    exit status 1
    Error compiling for board NodeMCU 1.0 (ESP-12E Module )


  • Mod

    @jhussain see earlier answers here



  • I went through the replies as pointed out but none solve the issue.

    I tried to close Arduino IDE 1.9.0 and start all over again but get the same compilation error.
    Any comprehensive solution will be appreciated.

    I can compile examples in IDE and they all run OK, so I do not think I have any hardware/software issue with IDE.

    Thanks.


  • Mod

    @jhussain downgrading the esp8266 board files to version 2.4.1 did not help?



  • @mfalkvidd You mean I should try 2.4.1? I will do that today or so and report back.

    Thanks.


 

284
Online

8.9k
Users

9.6k
Topics

101.0k
Posts