Please check my pcb design for 24V LED Dimmer



  • I just soldered my new pcb for a 24VDC led dimmer. However I can not load a bootloader. I checked the USBASP that I use, it is fully working.

    I checked connections, I checked the orientation of the microcontroller. But I fear I just did something completely wrong. This is my first time to use the bare chip.

    3631f508-1b97-4f48-a745-3bfa38101e2f-image.png

    031c12e7-672d-45b0-a54d-82aaf8668690-image.png

    IMG_20200514_235847.jpg IMG_20200514_235928.jpg



  • I found one problem. The ground of the atmega was never connected to the rest of the circuit. I solved this nou with a wire, but it has not fixed the problem.

    I soldered all the smd parts in a oven. Could this be a problem for some parts?

    I tried again. this time I did not connect the voltage converter. I used the power from the USBASP like I succesfully tested on a pro mini.

    I used a different brand for the crystal.

    Still nothing.

    Edit 3:
    16MHz crystal also no use


  • Admin

    Took a quick look, and one thing I noticed, is that you switched around the names for ftdi / isp pin headers.

    That is, you have MISO / MOSI etc. routed to the FTDI header, instead of the ISP header.



  • Yes, I noticed now as well.... Annoying but I was looking at the labels of the pins more than everything else.

    I found the problem. The bare chips that I have are fake.

    I transplanted one from a pro mini and now it works. This took me way to many hours to find out. What a waist of time.



  • I had very often issues with programming bare chips if any other connection is on MOSI/MISO or let’s say on the SPI. I would suggest to check your chips on a breadboard on load the boot loader before using them in a circuit. In your case it looks like you connected your 2.4g Radio as well to the ISP which in my cases always interfered with programming. I solved that by using jumpers to isolate the AVR when programming. Hope this helps preventing you from throwing away chips which might work...

    Good luck



  • @adfx Thanks for checking. I read once a blog/page about the use of multiple spi devices. It explained about the use of pull up resistors on the enable pin of every device you have on this bus for this specific problem. Just to be sure when I was testing it I did not connect the nrf24.

    I added that resistor to this PCB. So far it's works with the MySbootloader and just burning the program with the USBASP. Even with the nrf connected.

    I really believe that it was the chip itself. But I still have them waiting for a better test environment.


Log in to reply
 

Suggested Topics

  • 7
  • 7
  • 7
  • 323
  • 9
  • 12
  • 12
  • 25

199
Online

9.6k
Users

10.2k
Topics

106.2k
Posts