Remotes will not connect after latest compile



  • I have 3 remote nodes working off one gateway. The gateway is a ModeMCU 1.0 and remotes are Arduino Pro Minis. Radios are RFM69s. All 3 remotes have run great for about a year.

    Yesterday I made a minor change in the code that reads an analog voltage on one of the remote units. I compiled the new code and received an error message that “RFM69_getReceivingRSSI()” statement should be changed to “transportGetReceivingRSSI()” so I made that changed and the code compiled.
    I uploaded the new code and now that node will not connect to the gateway. The serial monitor log shows repeated TSM:FPAR:NO REPLY and then TSM:FPAR:FAIL. The other two remotes are still operating normally.

    I tried the troubleshooting steps including clearing the eeprom, and double checked the IDE settings, but still cannot connect. I also powered down the two working remotes and checked with MySController and all I see in the event log is
    “Gateway startup complete” and “2.3.2” messages. No other nodes.

    I had updated my Arduino IDE since the last programming was done about a year ago, and I did not track which versions I was using then. Current versions are IDE – 2.2.1, Pro Mini board – 1.8.6, and NodeMCU board – 3.1.2, MySensors library 2.3.2.

    I then decided to try monitoring one of the working remotes so I uncommented the debug statement and compiled (got the same warning about “RFM69_getReceivingRSSI()”). Now that remote will not connect either.

    I appears that the problem is related to my IDE but I cannot determine what it may be.

    Does anyone know what change would have triggered the “RFM69_getReceivingRSSI()” error and is it possible that that change is also causing the newly compiled code to not connect?



  • There are two drivers on the RFM69 which aren't compatible. Check if you are using the same one on nodes and gateway.

    MY_RFM69_NEW_DRIVER
    

    Also the radio settings have to match.

    https://www.mysensors.org/apidocs/group__RFM69SettingGrpPub.html



  • Thanks for the quick response.
    Yep! When I updated the IDE I forgot to modify the settings (915 MHz) in the new myconfig.h file.
    Doh!
    All good now.


Log in to reply
 

Suggested Topics

  • 3
  • 10
  • 2
  • 1
  • 24
  • 4

0
Online

11.2k
Users

11.1k
Topics

112.5k
Posts