Stuck with vrdude: verification error, first mismatch at byte 0x....



  • Hi

    Im trying to build a motion sensor using pro mini clone but every time i try to upload the sketch im getting error:

    vrdude: verification error, first mismatch at byte 0x...(last part change everytime)

    I can upload simple sketches like blink, but when trying anything from MySensors always fail. Early today I was able to upload the motion sensor sketch, but had no radio signal...when I started reuploading the sketch sometimes worked..sotimes it didn't....and now its not working at all.

    I've been reading about some windows 10 tp problems...but i'm using windows 7...so i think this is not the case.

    found on another forum that bootloader maybe corrupted....but in that case...simple sketches should fail too...am I right?

    if i need to reflash the arduino.....it can be done with the USBtoSerial adapter or do I need a programer?

    Thanks for your help


  • Admin

    Try switching USB cable (as short as you can find).



  • replaced cable....worked once

    but switched to board usb ports (was using a usb hub)....and now its working fine!!!!!

    weird thing is.....already used usb hub with nanos and Uno...and all worked fine...only this (my first) pro mini having this issues

    Thanks you very much


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.