Error sending switch command, check device/hardware !



  • Hi!
    I have the same behaviour on Domoticz running on a Raspberry PI type A Image v2.3530 or a Windows PC with Domoticz v2.3771.
    I've created DIY Humidity Motion and Door Sensors working fine.
    Unfortunately with Relay or Dimmer Sensors DIY, each time I try to turn ON or OFF, I have the same message: "Error sending switch command, check device/hardware !"
    I try to changed GW, sensors, ... but there is the same situation, and nothing is indicated in the Domoticz log.
    On the Sensor log, we can see only read and send from another sensor, but nothing from GW.
    I didn't implemant an inclusion button as all my sensors are listed in Domoticz; do you know where I could try to troubleshootig now please?
    Thanks for your help!


  • Hardware Contributor

    This happens to me on my switches as well if the power goes down and i need to restart Domoticz.
    Doesnt it work stright after you restart the node?
    The switch command isnt displayed in the log.


  • Admin

    The gateway code running on RPI doesn't remember routing information when restated (the EEPROM emulation is just in-memory).

    This means you have to restart the actuator nodes after RPI was restarted to fill the routing information again.

    It's on the grand TODO list. Anyone: Feel free to fix.



  • Hi,

    Despite I turn on and turn off the GW, turn on and turn off the RPI, and reinstall completely the GW, each time I reboot the RPI a new/same sensor appears:
    upload-f18eae08-3abe-40e6-ac13-851425909d7a
    If I click on Refresh, nothing happend. I try also to put the GW directly to the RPI, not through a USB port self powered for the same result. Last try is to reinstall Domoticz (already done a few days ago...but with not), or go to another interface on RPI for MySensors.


  • Hardware Contributor

    @Elfnoir Did you try to restart the sensor/actuator like Hek advised as all you have replied eith is that you have tried to restart the GW again.



  • Hi,

    I restart the sensor/actuator and the GW again without good results.
    But it appears I had 2 GW broken!

    Now I build a new one, and all is running good. Thanks!


  • Hardware Contributor

    It would have been nice to figure out the issue here so others had a solution, incase they was getting the same result.

    Glad to hear you have working gateways now though!



  • When the GW booting in Domoticz, I add no information on the Release used.
    In Domoticz, the Release was '?'
    I received all information from my sensors, but not able to send status modifications (ON/OFF).

    The GW I used was an arduino pro mini plugged in RPI with a TTL adaptator.
    Now I'm with an arduino UNO plugged directly to my RPI, and I purchased a NANO!


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.