Wifi gateway : NodeMCU & NRF24L01 - Radio does not work



  • Hi,
    Sorry for my English.
    I try to run the wifi gateway with a NodeMCU ESP12-E and a NRF24L01 (not 24L01+).
    Arduino ide is 1.6.7.
    Library sensors is Arduino-development. I tried before with the master library.
    radio power is independent of nodemcu.
    The wires are checked and connected as on documentation.
    First : in the sketch esp8266, i declare ssid, password, static ip address, everything works well.
    Second : I enable #define MY_RADIO_NRF24 and #define MY_RF24_DATARATE RF24_1MBPS. Then I get DHCP address (not static like above) and debug give :

    tail 0
    chksum 0x42
    csum 0x42
    0;0;3;0;9;Starting gateway (RNNGE-, 1.6.0-beta)
    write_register(0x04,0x5F)
    write_register(0x06,0x27)
    write_register(0x06,0x07)
    write_register(0x00,0x0E)
    write_register(0x07,0scandone
    x70)
    write_register(0x05,0x4C)
    write_register(0x00,0x0E)
    STATUS		0x0E RX_DR=0 TX_DS=0 MAX_RT=0 RX_P_NO=7 TX_FULL=0
    RX_ADDR_P0-1	0x0E0E0E0E0E 0303030303 
    RX_ADDR_P2-5	0xC3 C4 C5 C6 
    TX_ADDR		0x0E0E0E0E0E 
    RX_PW_P0-6	0x00 00 00 00 00 00 
    EN_AA		0x3Fstate: 0 -> 2 (b0)
    tate: 2 -> 0 (0)
    f 0, scandone
    state: 0 -> 2 (b0)
    state: 2 -> 3 (0)
    state: 3 -> 5 (10)
    add 0
    aid 1
    cnt 
    

    Have you an idea of the problem?
    Thanks for your help.



  • @miclane said:

    Hi,
    Sorry for my English.
    I try to run the wifi gateway with a NodeMCU ESP12-E and a NRF24L01 (not 24L01+).
    Arduino ide is 1.6.7.
    Library sensors is Arduino-development. I tried before with the master library.
    radio power is independent of nodemcu and grounds are interconnected.
    The wires are checked and connected as on documentation.
    I also changed several radio components.
    First : in the sketch esp8266, i declare ssid, password, static ip address, everything works well. I can successfully ping the ip address.
    Second : Now, I enable #define MY_RADIO_NRF24 and #define MY_RF24_DATARATE RF24_1MBPS in addition to the sketch. Then I get DHCP address - and not static like above - and debug give :
    Radio init failed - Check wiring.
    The radio connection is not working and disrupts the wifi connection.

    Have you an idea of the problem ?

    Thanks for your help.


  • Mod

    @miclane said:

    NRF24L01

    This chip is not supported by MySensors, sorry.



  • Thank you for your answer. I read a post indicating to change the speed of 1MB for L01 .
    I'll order L01 + .
    Congratulations on your achievement .


Log in to reply
 

Suggested Topics

217
Online

9.2k
Users

9.9k
Topics

103.2k
Posts