Arduino Uno Works, Nano not



  • I am building a motion sensor connecting to my ethernet gateway. When I make the sensor with Arduino Unos it works great. If I use same radio, sensor, cables and code with Arduino Nano's I get an "radio init fail".

    I triple checked cabling, the nanos etc. Also put a capacitor etc. but no success.

    Anybody has an idea why it works on UNOs but not on Nano's?


  • Hardware Contributor

    Sounds like a bad nano? Check power (3.3) with a multimeter to start with.
    Also try to upload some standard blinksketch and try the different pins the radio uses on the nano to see if something is broken



  • I checked Voltage which is fine. Also Nano is working fine (Blink etc). I actually tested with three different nano and all give me same result whereas the UNO's immediately work. Do I need to make any adjustments in the code if I use Nanos?


  • Hardware Contributor

    No, it should be the same.



  • Check the power at the radio and make sure it's getting ~3.3v . Are the nanos 5v or 3.3v?


  • Hardware Contributor

    Nanos are 5v but have both 5v and 3.3v outputs.



  • @soward Power and cabling has been checked. All is fine but I still get that error.


  • Hardware Contributor

    Does the Uno have a 3.3V-reg while Nano get 3.3V from it's Ftdi-chip (don't remember) Could Uno/Nano board selection in Arduino IDE effect the Ftdi behavior?


Log in to reply
 

374
Online

6.9k
Users

7.8k
Topics

82.8k
Posts

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.