Error compiling Sensebender Micro 1.4



  • I recently bought 2 Sensebender Micro, they worked straight away with FW version 1.1.
    When I download the sourcecode 1.4 and try to compile it, all seems to go OK until the linker is invoked, I get the folowing message:

    Arduino: 1.6.11 (Windows 7), Board:"Arduino Duemilanove or Diecimila, ATmega328"

    Linking everything together...
    "C:\Users\Gregory Weber\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.3-arduino2/bin/avr-gcc" -Os -flto -fuse-linker-plugin -Wl,--gc-sections -mmcu=atmega328p -o "C:\Users\GREGOR~1\AppData\Local\Temp\buildd219cddef0aa3a62d167b7fb84069ff4.tmp/SensebenderMicro.ino.elf" "C:\Users\GREGOR~1\AppData\Local\Temp\buildd219cddef0aa3a62d167b7fb84069ff4.tmp\sketch\SensebenderMicro.ino.cpp.o" "C:\Users\GREGOR~1\AppData\Local\Temp\buildd219cddef0aa3a62d167b7fb84069ff4.tmp\libraries\SPI\SPI.cpp.o" "C:\Users\GREGOR~1\AppData\Local\Temp\buildd219cddef0aa3a62d167b7fb84069ff4.tmp\libraries\Wire\Wire.cpp.o" "C:\Users\GREGOR~1\AppData\Local\Temp\buildd219cddef0aa3a62d167b7fb84069ff4.tmp\libraries\Wire\utility\twi.c.o" "C:\Users\GREGOR~1\AppData\Local\Temp\buildd219cddef0aa3a62d167b7fb84069ff4.tmp\libraries\RunningAverage\RunningAverage.cpp.o" "C:\Users\GREGOR~1\AppData\Local\Temp\buildd219cddef0aa3a62d167b7fb84069ff4.tmp/core\core.a" "-LC:\Users\GREGOR~1\AppData\Local\Temp\buildd219cddef0aa3a62d167b7fb84069ff4.tmp" -lm
    C:\Users\GREGOR~1\AppData\Local\Temp\ccf8ZNat.ltrans2.ltrans.o: In function `sendTempHumidityMeasurements(bool)':

    ccf8ZNat.ltrans2.o:(.text+0x1d0): undefined reference to `SI7021::getHumidityAndTemperature()'

    C:\Users\GREGOR~1\AppData\Local\Temp\ccf8ZNat.ltrans2.ltrans.o: In function `setup':

    ccf8ZNat.ltrans2.o:(.text+0x462): undefined reference to `SI7021::begin()'

    ccf8ZNat.ltrans2.o:(.text+0x508): undefined reference to `SI7021::begin()'

    C:\Users\GREGOR~1\AppData\Local\Temp\ccf8ZNat.ltrans3.ltrans.o: In function `global constructors keyed to 65535_0_SensebenderMicro.ino.cpp.o.2482':

    ccf8ZNat.ltrans3.o:(.text.startup+0xd8): undefined reference to `SI7021::SI7021()'

    collect2.exe: error: ld returned 1 exit status

    Bibliotheek SPI op versie 1.0 in map: C:\Users\Gregory Weber\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.14\libraries\SPI wordt gebruikt
    Bibliotheek MySensors op versie 2.0.0 in map: C:\Users\Gregory Weber\Documents\Arduino\libraries\MySensors wordt gebruikt
    Bibliotheek Wire op versie 1.0 in map: C:\Users\Gregory Weber\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.14\libraries\Wire wordt gebruikt
    Bibliotheek EEPROM op versie 2.0 in map: C:\Users\Gregory Weber\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.14\libraries\EEPROM wordt gebruikt
    Bibliotheek RunningAverage in map: C:\Users\Gregory Weber\Documents\Arduino\libraries\RunningAverage (legacy) wordt gebruikt
    exit status 1

    So far my Domoticz server is running on a Raspberry Pi 3 and I'm using an Arduino Uno as serial gateway, it didn't run on an Arduino Ethernet with softSPI for some reason.
    I have limited programming experience, let alone what goes wrong when libraries start yelling at me.
    Can someone guide me how to solve this?


  • Hero Member

    Where did you get the SI7021 library from? I had a similar problem and solved it by using the libraries from here: https://github.com/mysensors/MySensorsArduinoExamples



  • I've tried your suggestion, but errors keep comming. There is no keywords.txt there.
    Then I did a Google search and located 4 differtent versions, tried them all, but every time at linking time I keep getting errors like I had.


  • Admin

    keywords.txt is not mandatory.. it just hilight keywords in the Arduino IDE.



  • I took a drastic measure, uninstalled the whole lot, deleted all libraries, rebooted the PC and re-installed Arduino IDE, 1.6.12 now, installed MySensor-Master.zip, added the SI7021, ash204 and RunningAverage libs, from https://github.com/mysensors/MySensorsArduinoExamples/tree/master/libraries and guess what, still all the familiair error messages.
    When I took all the SI7021, ash204 and Flash items out it compiled nicely...
    My next challenge will be to add DS18B20 temp sensors, add the furnace controller logic (which works nicely on an Arduino Uno on the moment) and make it all visable in Domoticz.


 

313
Online

7.9k
Users

8.8k
Topics

93.8k
Posts